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PREFACE 

During our study of bobtail squids (Øresland & Oxby, 2021), we became interested in doing 

macro photogrammetry-based 3D models of them together with different organs including 

statoliths and otoliths. However, to our surprise, we found that 3D models of small animals and 

their organs were still not that widespread or commonly found on the Internet. More importantly, 

we could not find a suitable guide that included all the practical aspects of macro photogrammetry 

of small animals and their organs that we were looking for. We, therefore, decided to prepare one 

ourselves using a test specimen from a rubber, the digestive gland from a bobtail squid (Sepietta 

oweniana) and two cephalopods (the squid Illex coindetii and the octopus Eledone cirrhosa) as 

demonstration objects.  

3D modelling using macro photos can be demanding since photos with different focuses have to 

be stacked together (z-stacking) in order to produce a photo that is sharp throughout. In addition, 

nearby photos must overlap to 80 %. Different specimens will therefore give rise to different 

photographic challenges all of which cannot be foreseen here; just one example of many is 

gelatinous aquatic animals that must be photographed in water or, e.g., clear gelatine. This 

signifies that there is a large potential for creative photography.  

We used a microscope camera and the Nikon NIS-Elements software for z-stacking photos of the 

test specimen and the squid organ. The squids were photographed using a Nikon D500 DLRS 

camera equipped primarily with the DX macro lens AF-S Micro NIKKOR 85 mm and the 

software Helicon Remote and Helicon Focus for z-stacking. The z-stacked photos were then used 

for our 3D modelling which was carried out using the Agisoft Metashape Pro software, the use of 

which will also be described.  

The aim of this guide is to enable beginners with no prior knowledge to obtain an understanding 

of the equipment and skills needed to make their own 3D models. We describe, step by step, the 

process from animal collection and fixation/preservation to the final 3D models and how to share 

them with others. The process can be a challenge for the beginner (as it was for us) but we hope 

that this guide may help to avoid our mistakes as beginners and make 3D modelling a fun and easy 

experience. Finally, one must not forget that taking optimal photographs is the major challenge in 

photogrammetry; once achieved, the Agisoft Metashape software is subsequently able to provide 

3D models of high quality. The 3D models can be viewed in a number of software programmes 

like Agisoft Viewer, Adobe Acrobat, Power Point etc. Comments and suggestions are welcome (to 

be included in new PDF versions).  

  

Vidar Øresland & Gert Oxby 

Divers and Scientists West Coast Sweden 

2022 
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INTRODUCTION 

Why should one bother to make a 3D model when one can take photos from different angles? This 

question needs to be asked before any 3D modelling project is started and the answer will depend 

on the audience and aim: what should they see, reflect upon, investigate, and understand? 

Providing a combination of 3D models and photos can often be the optimal solution for audiences.  

There are many reasons for showing specimens as 3D models and /or as photos. 3D models for 

example could be preferable if one wants to attract attention during a PowerPoint presentation, or 

on the Internet thus enabling people to investigate and compare different models for themselves, 

as well as to estimate lengths, area and volume. Volume estimates can be used for many purposes, 

e.g., to estimate density (g/cm3). Note that when dealing with organ density one should consider 

using dry instead of wet weight since the blood vessels and other structures contain fluids (which 

may vary between samples). On the other hand, photos could be chosen if the specimens are to be 

shown and comparted at a specific angle and position (a good example is Pedà C. et al. (2022)) or 

when comparing complete specimens or magnified small-sized features side by side along with 

your additional remarks. It is also possible to make remarks in a 3D model. In addition, photos 

may be sharper and allow for higher magnification. Note that correct length and area estimates in a 

2D photo can only be achieved if it was taken at a 90-degree angle to the area of interest, 

something that is easily overlooked. However, in a 3D model, correct length and area estimates 

can be done regardless of viewing angle.  

Before producing 3D models of animals, we strongly recommend the beginner to make a simple 

and durable training specimen (see below). Finally, the photogrammetry industry is developing 

quite rapidly and we recommend regularly checking for software upgrades. It is, for example,  

already possible to jointly process laser scanning and photos (included in Metashape, but not dealt 

with here), providing benefits from both sources and avoiding some of their shortcomings. 

 

 

 

EQUIPMENT  

Camera, lenses, flash, batteries and macro focus rail slider 

In this guide we refer to the equipment that we ourselves used; however, this should not lead to 

any misunderstandings. We used the Nikon D500 APS-C DLRS camera (21MP, pixel size 0.0042 

mm) with the DX macro lenses AF-S Micro NIKKOR 85 mm 1:3.5 ED and the AF-S Micro 

NIKKOR 40 mm 1:2.8 G. From the photo quality point of view, one does not need a “full-frame” 

camera for macro photogrammetry of small animals. The cost of APS-C cameras and DX lenses is 

much lower and there is also a second-hand market offering good prices.  

We used the ring flash MS18 Macro with a LED light which is useful during focusing. This flash 

is fast, does not get overheated and is fully compatible with the camera. One should keep a 

number of loaded camera and flash batteries ready before starting the photography and two battery 

chargers for the camera and two for the flash. We used four camera batteries and six sets of flash 

batteries. Note that one might want to take thousands of photos in one day and charging batteries 

takes time.  

For manual macro focus, we used the Neewer Pro 4-Way Macro Focusing Focus Rail Slider (fig. 

1), which is both affordable and proficient. The camera is manually moved forward (to a 
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minimum) between each image so that the focus changes very little between them, as can be 

observed on the computer screen. The interval between two photos should be smaller than the 

depth of field (Part II describes the use of the camera rail slider). One should always use a manual 

camera trigger when the camera is not computer-controlled.  

 

 

Fig. 1. Neewer Pro 4-Way Macro Focusing Focus Rail Slider. This is an inexpensive but good 

quality item that worked very well for us, with the camera and flash weighing 1.7 kg. The camera 

is mounted on top of the rail slider.  

 

Camera stand, turntables and background 

A very steady camera stand that allows for taking z-stacked macro photos from all possible angles 

is a prerequisite when making a 3D model of small animals. Therefore, we do not use a tripod as 

the legs make it difficult to take optimal macro photos from all angles and tripods can also become 

unsteady at certain photo angles due to the weight of the camera equipment.  

Our inexpensive and easy-to-operate camera stand (fig. 2) was made from pieces of scaffolding, a 

61 cm long metal pipe that was 3 cm in diameter, a moveable shelf, a heavy 1 cm thick iron foot 

and the upper part of a camera tripod (to which the rail was mounted) that was fitted into an 

aluminium block (fig. 3). A piece of rubber attached under each corner of the foot makes the 

stand, together with its weight,  extremely stable. The height of the camera stand is 126 cm and its 

weight is 17.0 kg. 

On the moveable shelf we place our turntables. Fig. 4 shows a turntable for small specimens that 

we also use with stereomicroscopes. We also use a hand support (an old one made for stereo 
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microscopes) as a turntable (fig. 2 and 5) that can be rotated 360 degrees as well as turned 

backwards and forwards. Behind the camera stand, we have a movable and height-adjustable stand 

for a black cloth background. 

 

 

Fig. 2. Our camera stand and a mounted squid (Illex coindetii). 
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Fig. 3. This aluminium block can (after the release of its two locking mechanisms) be moved 

horizontally and rotated around the horizontal pipe (which in turn can be moved up and down and 

around the vertical scaffolding pipe).  

 

 

Fig. 4. A turntable designed for small specimens often used with stereomicroscopes. Note that one 

can drill holes and attach needles for keeping a petri glass or a specimen in place during rotations 

(and at the same time place a black background photo). 
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Fig 5. We used a hand support for stereo microscopes as a turntable that can be rotated 360 

degrees as well as turned backwards and forwards. This squid (Illex coindetii) was a test specimen 

that was used many times and therefore in bad condition. See below, Mounting, how to mount a 

squid.   



11 

 

Microscopes 

When photographing smaller specimens, we used: the Wild M3Z stereo microscope; up to four 

movable stereomicroscope lights; and the microscope camera DFK33UX250 (5MB). One can use 

an oblique viewer (fig. 6) mounted on a stereomicroscope (which makes it possible to take 

photographs from the side) but this would have to be calibrated (see Part II) and used for all the 

photos that are part of a 3D model. It should be noted that our stereomicroscope Wild M3Z has a 

Type S holder attached  (fig. 6) which makes it possible to take “one light beam “ photos, an 

essential addition when creating 3D models (see Part II, Microscope photography). Tips for 

photography using microscopes and microdissection techniques can be found in Øresland & Oxby 

(2021). Note that an inverted compound microscope can be used for 3D modelling of small 

objects like statoliths and otoliths. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig. 6. An oblique viewer (type 404233) by Wild Heerbrugg. Our Wild M3Z is equipped with a 

Type S holder which is capable of providing a single light beam (see below, Microscope 

photography). 
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Computers 

To improve data security and speed up the process of data processing, we used two computers: 

one with a good memory capacity and high screen resolution for photography, photo storage and 

3D modelling. This computer (Windows 10, 64 bit) has 32GB of RAM which should, as a very 

rough guide, be considered a minimum (but worked fine for us), and an NVIDIA GeForce RTX 

3060 graphic card. The other computer was used for data recording, the Internet, and for all other 

purposes. Photography and data collection are time and labour-intensive and will, over time, 

represent months and years of work. Therefore, we tried to avoid having our computer for 

photography connected to the Internet and used good protection software on both computers. It is 

important to have at least two backup memories and to have an additional backup in another 

location. Backups should be made daily. A tried and tested, easy-to-use, folder system should be 

utilised since data and photos will be extensive and diverse. More information about our folder 

system is found in Part II and III. A data table should be created where all the scientific 

information can be tabulated from left to right as soon as it is obtained.  

Training specimen 

It is advisable to make a simple and durable training model before commencing the 3D modelling. 

We made one from a rubber which we cut at different angles and coloured (fig. 7). A hard plastic 

or metal model of a specified volume and area, plus a mm scale, would be even better since the 

resulting 3D model could be checked more easily. One should make sure that the model has many 

identifiable feature points and do not create glares during the photography. It is important to 

ensure that the Metashape Pro settings are correct in order to produce accurate length, area and 

volume estimates (see Part III,  MEASUREMENTS). There is no room for error if the estimates 

are to be utilized scientifically. 

Fig. 7. Our test specimen was made from a rubber. The 3D model can be viewed in the PDF 

version using Adobe Acrobat Reader (click the figure). 
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SOFTWARE   

Helicon Remote and Helicon Focus  

We used the integrated Helicon Remote (3.9.12 W) and Helicon Focus (8.2.0) software that is 

easy to use and which together produce sharp z-stacked images (Part II). When connecting the 

Nikon D500 camera to Helicon Remote one will get computer control of its settings, with the 

possibility of direct storage of photos, without using a camera memory card, which will save 

considerable time. The principle behind z-stacking is that a number of photos are taken with 

sharpness in different planes, from the front of the specimen to the back or the other way around. 

Once completed, a click on the Helicon Focus icon (inside Helicon Remote) enables the images to 

be inspected and z-stacked into one. This sharp z-stacked image and all partially blurred initial 

images (often 20 - 60 images) should now be saved and it is possible to test different z-stacking 

settings, if necessary. 

One should first make all the camera and flash settings needed, take a test photo, and then connect 

the cable between the camera and the computer. When photos are taken in the field without 

computer access, they can be imported to the Helicon Focus using the camera memory card. Note 

that images can be taken both manually and automatically in Helicon Remote, but we use only 

manually captured images in 3D modelling with Metashape (see below and Part III) since our 

rail slider is manual. The Helicon Remote Automatic focus bracketing cannot be used here since 

the 3D modelling requires a fixed camera focus (see Part II, Choosing macro lens and focal 

distance). When taking photos in microscopes we did all the above using the NIS - elements 

software (see below and Part II and III). 

 

Nikon NIS-Elements   

When doing microscope photography of small organs (including our rubber model, fig. 7), we 

used our microscope camera and the NIS-Elements software (5.02.03) to produce sharp z-stacked 

images. The NIS software is also used to estimate distances in both microscope photos and Nikon 

D500 camera photos (Part II). The NIS z-stacking is very easy to do and much quicker than using 

the Nikon D500 and the rail slider together with the Helicon software (Part II, TAKING 

PHOTOS AND Z-STACKING). 

 

Agisoft Metashape Pro 

The Agisoft Metashape comes in both a professional (we used version 1.8.4) and a standard 

edition (where one cannot make estimates of the distance, area, and volume and which also lacks a 

number of other options). However, the standard edition comes at a very reasonable price, is a 

good choice for beginners, and is a useful introduction to the pro edition since the overall structure 

is the same. Metashape is produced for a number of applications but here we are only concerned 

with its relevance to the 3D modelling of small animals. Once all the z-stacked photos are taken 

one can import the photo folder to Metashape and follow the instructions given in Part III. 

Additional photos can always be imported at a later stage. Additional software from Agisoft (free 

down load) that we used was Agisoft Viewer (to visualize 3D data) and Agisoft De-lighter (to 

remove shadows from model textures). We also used Adobe Acrobat Pro to insert 3D models 

into PDF documents (Appendix III). 
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ANIMALS  

Collection and preservation   

Since 3D modelling of small animals is a labour-intensive task, it is important to obtain specimens 

in perfect condition. Collection, anesthetic, and preservation methods for invertebrate animals can 

be found in Lincoln  & Sheals (1985), Øresland & Oxby (2021) and on the Internet. Marine 

animals can be obtained from, e.g., fish markets, fishermen, museums, research institutes, divers, 

or found on the beach, etc. Even if the models are not intended for research purposes one should 

always note important collection data such as date, exact location, collection method and the 

collector´s name (as a minimum). The data should be noted (using a soft lead pencil), on a 

waterproof label that is kept with the animal inside a bag or jar, directly after the collection.  

1. Determine whether the specimen (a whole individual or an organ) is worth 3D modelling or 

being photographed for 2D image purposes: no external damage, lost parts or discolourations. 

2. Give the specimen an individual ID code and tabulate all collection data in a general data file. 

3. Decide whether the specimen should be photographed in water, air or gelatine, etc.   

4. Does the specimen has to be preserved, stained, dissected, or fixed in a certain position? 

5, If possible, the specimen should be fixed in its preferred position prior to the fixation/ 

preservation. 

One can use fresh or live animals as long as they don’t´ move or change appearance during 

photography, otherwise, the animals have to be killed and preserved or at least immobilized. What 

is the desired appearance of the specimen (standing, lying, attacking, open mouth, etc)? 

Sometimes one wants to model only a part of the animal, e.g., a snake’s head. The animals can be 

anaesthetized until near death before preservation in order to reduce contraction. One can use 4% 

formaldehyde in freshwater (buffered to ~ pH 7 using borax (Na2B4O7·10H2O) or 70-96 % ethanol 

as preservatives. However, there are a few things to consider before preservation can commence. 

Preservatives may affect the animal’s appearance permanently (shrinking, bending, colour); some 

parts of the animal (e.g., squid arms, tentacle clubs, and fins) may first need to be fixed prior to 

preservation in order to prevent bending. If the specimen is already preserved and its position 

needs to be changed, one can put it in water for 24 hours (change most of the water 3-4 times) 

prior to the final fixation. The arms of a squid, e.g., may then soften a bit and can, hopefully, be 

stretched out in the preferred positions. Finally, and most importantly, one must be able to take 

photos from every angle after the position has been corrected.  

Figs. 8 and 9 show our fixation tube for squids and how the squid arms can be fixed in optimal 

positions. First, a sewer pipe of appropriate length and width was cut and then we glued a piece of 

plastic at the top, with a central oval-shaped opening to fit the squid mantle and fins. Pieces of 

Velcro were attached to the plastic and to two half-moon-shaped pieces of cork, both of which 

have a half-circle opening that becomes a full circle when the cork pieces are put together. The 

squid is put through the plastic hole and between the cork pieces from above, leaving the arms and 

tentacles above the cork. The cork pieces are then moved towards the squid’s head, and the cork 

pieces can be attached to the plastic piece. The arms and the tentacles can subsequently be fixed to 

the cork using pins and/or stripes of water-resistant field notepaper and pins. Before inserting the 

squid, its fins should be fixed between thin pieces of stiff plastic that are held together with tape. 

Finally, the fixation tube is put into a plastic bucket with 4 % formaldehyde and lead weights are 

put above the cork to keep the fixation tube in place. The squid in fig 9 was already preserved and 
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then put in water  for 24 hours to soften it prior to the preservation on the cork. As can be seen in 

fig. 9, we could not stretch out the arms as much as desired. Clearly, the best option is to fix the 

positions of fresh specimens before adding preservatives.  

We use 4 % formaldehyde since it fixes the position of the arms and tentacles better than ethanol 

and does not deform the animals or their inner organs as much as ethanol can in some cases. 

Formaldehyde can affect one´s health and should be treated with caution, e.g., by wearing gloves 

and avoiding inhaling the fumes. After three days the specimen can be removed from the fixation 

tube and put in water overnight in order to remove the formaldehyde fumes before mounting (see 

below). When using ethanol, we started with 20 % for 24 h, then 40% for 48 h, and finally 80 % 

for seven days. This stepwise preservation makes the squid softer and not so deformed as is often 

the case when put directly into 80 % ethanol.  

We definitely prefer ethanol (which is not dangerous to inhale) for our reference collection of 

squids as they are often taken out of their jars for examination and comparison with other 

individuals. Once animals are in their final ethanol concentration or 4 % formaldehyde they can 

remain there for years. However, preservatives may affect the colour and shape of the specimen, 

though different species and organs may react differently. It is therefore advisable to keep the 

specimens in the preservation fluid for as short a time as possible before starting the photography. 

If it´s uncertain when the work can begin, one should consider deep-freezing the fresh animal 

before fixation and preservation in formaldehyde or ethanol. Deep-freezing, can, however, dry out 

soft-skinned animals so they should first be put into a moistened plastic bag with a minimum of 

air. One can also test how different animals are affected by deep freezing in water and the 

following thawing. 

 

 

Fig. 8. A fixation and preservation tube for squids with the moveable cork pieces and the white 

pieces of Velcro between the cork and the plastic. 
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Fig 9. An eight-armed Eledone cirrhosa is fixed to the cork of the preservation tube using water-

resistant field notepaper and pins. The specimen had been preserved in 4% formaldehyde prior to 

this and the arms could therefore not be stretched out in full in the preferred positions, despite 

being in water for 24 hours. 

 

Mounting   

Staining must be carried out prior to mounting and in some cases even before fixation depending 

on the dye used (see Øresland & Oxby, 2021). If one cannot move the animal around (e.g., on top 

of a turntable or in a petri dish) without affecting its shape, it must be mounted. Fig. 5 shows a 

turntable with a woodblock glued to it and a squid attached to a black metal bar. Two other bars 

with needles at one end fix the position of the squid tentacles. Make sure that the metal bar 

thickness and length are optimal (too long and thin will cause vibrations and too short will make it 

difficult to take photos from underneath. Sharpen the bars to facilitate mounting. Note that a 

number of holes (drilled at different angles) in the woodblock makes it easier to fix the tentacles in 
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an optimal position. It is crucial that no parts of the animal can move during photography (this is 

why we prefer formaldehyde which makes the animals more rigid). If the photography session has 

to continue on another day, one must not remove the squid from the turntable! Instead, one should 

simply turn it upside down into the preservative, keeping the table in the air by resting it on two 

pieces of wood over the container opening. All the arm and tentacle photography should be taken 

during the first photo session in case their fixed positions change. 
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INTRODUCTION 

                                                                                                                                                         

We are now going to deal with the all-important preparations and photography before we make the  

3D model in Part III. The two Helicon and the Nikon NIS-Elements software programmes are 

easy to use and we have chosen to concentrate on the necessary preparations and insights that will 

help to achieve an optimal z-stacked macro photo and a series of such photos, which together meet 

the requirements of a good Agisoft Metashape 3D model. The crucial importance of optimal 

photos should not be underestimated. Macro photography can be demanding but we hereby 

provide solutions for the commonly met problems (see also Øresland & Oxby, 2021). Finally, it´s 

all about preparation and photography! 

 

 

 

 

PREPARATIONS   
 

Folder system for photos and 3d models  

                                                                                                                                                         

There are a number of things that should be considered before starting photography. First of all, 

one should create, and test, a practical photo and 3D model folder system in order to easily save 

and find all files, as well as making a data table (we use Excel for tabulating all specimen data, 

from collection to 3D model analyses). Note that Metashape cannot locate the files if their file 

names have been changed during the 3D process. If folders have been renamed or their positions 

in the folder system have been changed, during, e.g., model copying, their new positions can be 

specified using the Change Path command. We will deal with this problem in Part III, Saving 

models. We show below a general folder system used for all our 3D projects.   

  

D/3D PROJECTS/DATA/3D EXCEL DATA; PHOTOS/ 

Under 3D EXCEL DATA we save our Excel data file containing all specimen data and under 

PHOTOS there are five main folders: 

 

A. MICROSCOPE CALIBRATION PHOTOS  

B. NIKON D500 CALIBRATION PHOTOS 

C. BLANK PHOTO FOLDERS TO BE COPIED TO D 

D. 3D PROJECTS 

E. TESTS 

   

The main folders A and B contain all the microscope and Nikon D500 calibration photos for all 

3D models and 2D photos used in all 3D projects.    

The main folder C. BLANK PHOTO FOLDERS TO BE COPIED TO D contains two empty 

folders: SPECIMEN and ORGANS. Under both these folders we have seven empty sub folders 

into which the photos and 3D files are saved: 

 

1. FRESH AND PRESERVED. For 2D presentation photos of the whole specimen or organ. 

 

2. ESTIMATING NO OF PHOTOS REQUIRED. For estimating the positions and number of z-

stacked photos that will be needed (with 80% overlap). 
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3. 2D SCALE PHOTOS. For “scale photos” for the 3D model and 2D presentation photos that 

need a scale bar. 

 

4. Z-STACKED PHOTOS. For the microscope and Nikon D500 z-stacked photos to be used in 

the 3D model. 

  

5. Z-STACKED PHOTOSHOP. For copies of Z-stacked photos to be used for Photoshop 

adjustments. These images replace (when needed) the z-stacked photos used just before 

Texture (see Part III). Note: The file names (just a running number) must be identical to the 

original ones and the photos must not be cropped. 

 

6. 3D MODELS. For 3D model in progress. 

 

7. FINAL 3D MODELS AND 2D PHOTOS. For different final 3D models and 2D photos to be 

used for publication and other purposes, like PowerPoint, and Agisoft Viewer models etc. The 

report (see Part III) and the 3D project`s data file should also be saved here. Keep all files 

that are relevant to the 3D model in this folder. 

 

   

The main folder D. 3D PROJECTS contains all our 3D projects, old ones as well as those in 

progress. Here one creates and name a project folder, using the ID code, and the Specimen and 

Organ folders (including the subfolders 1-7 shown above) are copied from C. BLANK PHOTO 

FOLDERS TO BE COPIED TO D and pasted into the new project.  

 

The main folder E. TESTS is used to save tests that may or may not be deleted after use. We also 

use it for saving the original Helicon Remote photos which can be deleted after z-stacking (see 

below, Nikon D500 photography). 

 

ID codes. The 3D models, photos, Excel data, labels used for jars and vials etc. were each given 

the specimen ID code. However, the photos used for z-stacking (Helicon only) and the z-stacked 

photos were given a running number (to save time). How to create and use ID codes is very much 

a personal choice but they should be informative and consistent. Our ID codes consist of 

lowercase letters, numbers, dots and hyphens with no spaces between.  

 

 

Photography room   

 

1. Clean the microscope objective(s) and oculars: remove as much dust and dirt as possible with 

a blower or soft-bristled brush; apply a few drops of lens-cleaning solution to a lens paper or a 

cleaning cloth and using a circular motion, working from the centre outwards, to gently remove 

fingerprints, oil and grime from the lens surface. Never remove the camera from the 

microscope since it protects the inside of both from dirt that can be very difficult to remove! 

Make sure that the camera is tightly connected to the photo tube adapter. Always use a plastic 

hood for the microscopes and cameras when not in use! 

 

2. Check the magnification calibrations of microscopes and stereomicroscopes against a glass 

slide micrometer using NIS-Elements (see below, Microscope magnification calibrations). 

https://www.bhphotovideo.com/c/buy/Blowers-Compressed-Air/ci/18806/N/4077634545
https://www.bhphotovideo.com/c/buy/atclk/Lens+Cleaner+Type/Brushes/ci/18804/N/4077634488+4126061399
https://www.bhphotovideo.com/c/buy/atclk/Lens+Cleaner+Type/Liquid+Cleaners/ci/18804/N/4077634488+4126061401
https://www.bhphotovideo.com/c/buy/atclk/Lens+Cleaner+Type/Lens+Tissue+Wipes/ci/18804/N/4077634488+4126061400
https://www.bhphotovideo.com/c/buy/atclk/Lens+Cleaner+Type/Microfiber+Cloths/ci/18804/N/4077634488+4126061402
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3. Have available different solutions of dyes, sharp dissection tools, microscope lights, Petri glass 

dishes, distilled water and a black background, etc., ready for dissection and photography (see 

Øresland & Oxby, 2021). 

4. Keep an ultra-fine spray bottle at hand to moisten the specimen (with distilled water) and use a 

paper to protect the flash, camera and microscope objective(s).  

5. Have lens paper ready to absorb any excess water on the specimen. 

6.  Have black sprayed metal rods of optimal length and thickness ready for mounting the 

specimen. 

7. Cut out small pieces of lead to support small organs from underneath when in a Petri dish 

during microscope photography. However, one should consider mounting the organ on a needle 

connected to a small turntable (fig. 5).  

8. Have available a small flashlight/headlamp in order to see the camera settings and keyboards, 

etc., when the photo room is blacked out. Have no other lights on except for one computer 

screen in use (use blackout curtains and keep doors closed).  

 

Microscope ocular adjustment  

The most common microscope oculars used have a magnification of 10x. Adjust the 

stereomicroscope ocular appropriately (with or without glasses). Make a cross on a piece of paper 

with a graphite pencil and place it flat under the stereomicroscope. Set both oculars to zero and 

obtain sharpness, using the focus knobs, at the highest magnification. Then choose the lowest 

magnification, without moving the focus knobs, and adjust the oculars individually for optimum 

sharpness. One can thus change from low to high magnification with a minimum of focus 

adjustment. Tape the ocular scale settings. Compound microscope oculars are adjusted directly 

i.e., in accordance with one´s sight. We use the oculars primarily during dissection and when 

removing small parts that do not belong to an organ.  

 

Microscope magnification calibrations   

A compound microscope (not used in this guide) has objectives of different quality and 

magnifications (often 4x, 10x, 20x, 40x, 60x and 100x). A stereomicroscope can also have 

objectives with different quality and magnifications (0.5x, 1x, and 2x) and zoom capability to 

provide different total magnifications. The two zoom knobs have different numbers marked on 

them which, when multiplied by the ocular and objective magnifications, give different total 

magnifications. However, some stereo microscopes (such as our Wild M3Z) assume a 1x 

objective and a 1x ocular, in which case the zoom knob numbers give the total magnification 

directly. A 0.5x objective will give half the magnification. It is very important to set the zoom 

knob to “fixed step zoom” instead of a continuous zoom. 

In order to estimate distance, area and volume in a 3D model (and distance in a 2D photo) one has 

to calibrate (in NIS) both the microscope magnification to be used and the Nikon D500 x/y frame 

size in mm for the chosen macro lens and focal distance (see below, Nikon D500 frame size). In 

Part III we will use the microscope magnification calibration and the Nikon D500 frame size 

calibration to estimate the distance between known points in  “scale photos” (in NIS) and to make 

scale bars in 3D models in Metashape (see below, Scale photos for 3D models and Part III, 

Bundle alignment and making scales). Before the microscope calibrations starts: make sure that 
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the camera fits tightly to the photo tube adapter and set the stereomicroscope to “one beam” (see 

above, Part I, Microscopes). Make a “quick calibration” in NIS of the compound microscope 

objectives and the different “fixed” zoom magnifications of the stereomicroscope using a glass 

slide micrometer and the microscope camera. Save the calibrations on the NIS access bar with a 

shortcode: e.g., 40wild1.0x (zoom knob number, microscope name, and objective magnification) 

and remove old shortcodes. Obviously, one only need to calibrate the chosen compound 

microscope objective or stereo microscope “fixed“ zoom magnification.  

Make a distance measurement, using the relevant shortcode (check that the microscope 

magnification and the shortcode in NIS are in compliance), take a photo and burn the distance line 

and the estimated length data in to it and save the photo (fig. 10) in the main folder A. 

MICROSCOPE MAGNIFICATION CALIBRATION PHOTOS. The photo file name should consist of 

the date, microscope name, objective magnification and zoom knob number for 

stereomicroscopes (e.g., 08-08-2022wildm3z-obj1.0x-zoom 40). Note that if an oblique viewer is 

used, it must be calibrated for the selected magnification and viewer angle (to be taped!), which 

must be specified in the calibration photo file name.  

Do not delete old calibration photos used for old photos since one may need to validate 

measurements made on them as well as making new ones (after making a new “quick calibration” 

shortcode using a slide micrometer). Always check the shortcode to be used against a slide 

micrometer before starting a photo session. It often happens that one must recalibrate! However, 

a small deviation can be due to an inadequate focus setting. Any distance in a microscope photo 

can now be estimated using NIS by choosing the correct shortcode (see below, TAKING 

PHOTOS AND Z-STACKING).    

 

   

 

 

 

 

 

 

 

 

 

  Fig. 10. A stereo microscope magnification calibration (08-08-2022wildm3z-obj1.0x-zoom40) 

was here tested by measuring a 2 mm long distance in a glass slide micrometer. 

 

The Nikon D500 camera and flash settings  

1. Clean both the camera lens and the camera sensor (the wrench icon in the camera menu). 

2. Charge all camera and flash batteries before each new photo session.  
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3. Set the flash compensation to 0 (to start with). Use the TLL setting for automatic camera 

control of the flash and manual flash compensation. 

4. Set the camera to: single shot; HDR off; mirror lock up (MUP); matrix measurement (not 

spot); and lens and camera focus to manual. Automatic “picture rotation” and “rotate high” 

should be off. Set the ISO to 100 (must not be changed during a 3D project), the exposure 

time to 1/250 s, and start with an aperture of f /8 (see sweet spot, below). Set the camera 

exposure compensation to 0. White balance settings; see below, Light and natural colour.   

 

Choosing macro lens and focal distance  

Here we compare a 40 mm macro lens and an 85 mm macro lens. The choice of macro lens and 

focal distance demands a compromise between the time spent on the photography and the 

sharpness and zoom/enlargement capability of the 3D model. For example, a 40 mm lens will give 

a large photo area, thus needing fewer z-stacked photos to cover the specimen/organ. However, an 

85 mm lens gives a smaller photo area (with more pixels per area) that enables greater 

enlargement (which might be useful for PowerPoint presentations) but more z-stacked photos are 

needed. Since the z-stacked photos must overlap by 80 %, many photos have to be taken; the time 

saved by using a 40 mm lens can therefore be considerable. However, this can be avoided by 

using an 85 mm macro lens set to a larger focal distance providing a larger photo area (frame 

size). The 85 mm lens can thus provide the user with a higher degree of flexibility when it comes 

to macro photography.  

Since Metashape requires that all photos depict the specimen with exactly the same magnification, 

frame size and x/y pixel numbers, the chosen focal distance on the macro lens must be fixed. The 

focal distance should be taped so that it cannot be accidentally changed. One must then manually 

move the camera forward (or backward) so that all images, each focused on different parts of the 

specimen, can be taken for z-stacking. This is achieved by the use of a macro focus rail slider (fig. 

1). 

A camera lens “sweet spot” refers to the aperture that will give a minimal amount of aberration 

and diffraction and hence produces the sharpest image. For most lenses, the sweet spot is around 

f/8. However, when taking macro photos for z-stacking one may wish to go somewhat higher than 

that in order to increase the depth of focus and thereby reduce the number of photos needed. 

Avoid using different f-settings in order to save time and effort. 

 

Nikon D500 frame size    

As shown previously, (Microscope magnification calibrations) we used the “quick calibration” 

in NIS to calibrate different microscope magnifications using a glass slide micrometer and making 

magnification shortcodes. However, when using “quick calibration” to make a magnification 

shortcode for a Nikon D500 photo, one must first estimate in mm the total horizontal and vertical 

distances that the photo will depict (frame size). The NIS shortcode is used later to calibrate 

“scale photos” to be taken during the Nikon D500 z-stacking photography (see below, Scale 

photos for 3D models and Part III, 3. Bundle alignment).   
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Here we use our Micro NIKKOR 85 mm macro lens as an example and tape the chosen focal 

distance at 0.35 m. The focal distance is that from the subject area in focus to the camera sensor. 

Using the camera stand, take two calibration photos, at a 90-degree angle from above, of a slide 

micrometer (or a ruler for large focal distances/large photo frame sizes) so that its scale covers the 

photo width (fig. 11) and then its heigh. In this case, these are approximately 45/30mm (always 

check that the width/height correlation equals that of the Nikon D500 camera Image sensor: 23.5 x 

15.7 mm (CMOS sensor). Save the photos in the main folder B. NIKON D500 CALIBRATION 

PHOTOS. Name the calibration photo files with date, camera, lens, focal distance, and width (w) 

or height (h), e.g., 03-05-2022 Nikon D500 macro Nikkor 85 mm-fd0.35 w45mm.  

Finally, we make a “quick calibration” in NIS by opening the “width photo” and calibrating it 

using the known width distance. Save the calibrations on the NIS access bar with a shortcode, 

e.g., NIK85mmfd0.35. Measure any distance using a glass slide micrometer or ruler in order to 

check the calibration.  

 

 

Fig. 11. A scale photo (03-05-2022 Nikon D500 macro Nikkor 85 mm-fd0.35 w45mm) taken of a 

metal ruler using a Nikon D500 camera and Micro NIKKOR 85 mm macro lens and a focal 

distance set to 0.35 m. The frame width is 45 mm in this case. 

 

Light and natural colour settings     

Lighting and images resolution affect the aligned photos result, 3D model quality and model 

texture and should be taken into account when planning the photography session. Take test 

images and check for uniform lighting and natural colours. Ensure that there are no too dark or 

light areas or any reflexions in the photo. During stereomicroscope photography we use 

stereomicroscope lights only (some with simple modifications, see Øresland & Oxby (2021)). 

Turn on the first extra light, reposition it as needed. Add more lights if necessary (we use up to 

four lights). During Nikon D500 photography we use primarily the flash but also 

stereomicroscope light when needed. Set the flash lighting compensation to 0.0, increasing it if 

more light is needed. If the maximum flash compensation and extra light are inadequate one can 

increase the camera exposure compensation. If one side of the specimen needs to be brighter, the 
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flash ratio can be changed or one can try changing the photo angle. Do not forget to check and 

change lightning when needed during the photography in order to make all photos equivalent. 

 

The lighting used can affect the colours of the photos. For example, a higher flash compensation 

value can remove yellowish shades. The Nikon D500 has different white balance settings that can 

be used for optimal colours:  

1. Kelvin setting. Press the WB (white balance) button and check the control pane. The current 

setting is at the top and at the bottom there are small icons that can be selected by pressing the WB 

button while turning the main command dial (e.g., k = kelvin; if k is selected, then turn the camera 

sub-command dial to 5560 k (5600 k is optimal for MF18 Macro).   

2. Select the Menu button > camera > white balance > auto > OK; press the WB and the letters 

WB A is shown in the control pane.  

3. Select the Menu button > camera > white balance > flash > right-click the multi selector; 

chose a colour compensation from the colour chart (if needed) > OK; press the WB and the letters 

WB and a flash symbol is shown in the control pane. We normally use this alternative as it enables 

the colours to be controlled manually. Check that the shutter speed of 1/250 s has not changed!  

 

Estimating the number of photos required  

In order to estimate the number of z-stacked photos (microscope or Nikon D500 photos) required 

for a 3D model, one can project the image frame size on photos of the specimen. One should take 

6 photos around the specimen. With increasing experience, this kind of estimation should not be 

necessary.   

1. Mount the specimen on a turntable or put it in a Petri dish.   

2. Take a photo of the whole specimen then rotate the turntable (or the specimen in a Petri dish) 60 

degrees and take another photo, repeat the process until 6 photos have been taken. 

3. Save the photos in photo folder 2. FLAT SCALE PHOTOS (File name: ID code +required 

photos+1-6). 

4. Take a macro photo (using the correct lens and focal distance) which shows only the specimen 

surface (no background). 

5. Open the first of the six photos in Paint 3D and use the macro photo above to make a rectangle 

that corresponds to the macro photo area. This is only a rough estimation so do not spend too 

much time to make it accurate. 

 

6. Copy the rectangle and move it 20 % (to get an 80 % overlap) fig.12) and so on until the photo 

is covered with rectangles.     

7. Repeat for the remaining photos. 

8. Count all rectangles. 

9. Decide whether or not to change macro lens or focal distance.  
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  Use these photos, at least for the first models, as a guide when making the z-stacked photos.   

Note that more than 80 % overlap is required for photos of areas with sharp corners (like the 

outer part of fins). 

 

 

Fig. 12. One of 6 photos, each taken with a 60-degree rotation of the turntable. Here we started to 

place seven rectangles with 80 % overlap. The number of photos needed under and between the 

arms can be estimated by eye, or one may take more photographs and place rectangles on them as 

well.  

In conclusion, check, via practical tests, that the chosen microscope magnification or Nikon D500 

macro lens and focal distance will provide high-quality photos that allow for any necessary 

enlargement of the final 3D model. Finally, make a rough calculation of the required number of z-

stacked photos. The number of photos needed for a z-stacked photo depends on the specimen’s 3D 

appearance, the chosen lens, focal distance and aperture. Note that making z-stacked photos using 

a microscope camera and NIS-Elements is much quicker than using the Nikon D500 camera, 

manual rail slider and the Helicon software. 
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GENERAL WORKFLOW  

Whole specimens  

1. All field data should be written on a waterproof label (using a graphite pencil) kept inside the 

preservation jar (or plastic bag in deep freezer) and the ID code put on the outside.  

2. The fresh specimen. Weigh and measure standard lengths and tabulate all specified data in a 

data table (e.g., ID code, species, sex, catch date, name of the locality, position, depth, 

collection method, collector, preservation method, weight, standard lengths, comments).  

3. 2D photos for presentation purposes. Take at least two photos with the same frame size (using 

a microscope camera or the Nikon D500 camera) of the fresh (if possible) specimen against an 

appropriate background. The first photo must include a specimen ID code label and a glass 

slide micrometer or a ruler covering the width of the image (needed for making a length scale 

in the other photos, using NIS-Elements). Save the photos in folder 1. FRESH and 

PRESERVED.  

4.  Deep freeze the specimen if it cannot be fixed immediately in the preferred position in a 

preservative. Note that preservation fluid affects the specimen size and possibly colour. 

5. The fixed and preserved specimen. Put the specimen in water 6 to 12 hours to eliminate the 

smell of formaldehyde. 

6. Remove all particles, even small ones, that do not belong to the specimen (except for 

epibionts). 

7. Weigh and measure standard lengths of the preserved specimen and tabulate them as above. 

   8. Is it necessary to use dyes (see Øresland & Oxby, 2021)?  

9. If needed, mount the specimen at the appropriate height on a black metal rod so that photos 

can be taken from all angles.  

10. Take test photos in order to optimize correct lighting and natural colours. 

11. Take photos for z-stacking and save the z-stacked photo in photo folder 5. Z-STACKED 

PHOTOS. At least five z-stacked “scale photos (at 90 degrees) have to be taken for later scaling 

of the 3D model. 

12. Start Agisoft Metashape 3D modelling using the z-stacked photos (Part III). 

13. Check if more z-stacked images are needed. If the photos are not overlapped enough one can get 

holes in the 3D model (see below and Part III), in which case no area and volume estimates 

can be made.   

14. Save the final 3D model in folder 7. FINAL 3D MODELS AND 2 D PHOTOS and make 

BACKUPS. 

15. The specimen can now be taken off the rod and put in a jar with formaldehyde for later 

dissection of external and internal organs (if not destroyed by the rod).  

 

 Organs  

1. Dissect the formaldehyde-preserved specimen for all organs of interest (see Øresland & Oxby, 

2021) and save them in formaldehyde in separate vials with an ID code label + name of organ 
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(inside and outside the vial). It is of course possible to dissect the fresh or thawed specimen, in 

which case the data for each organ should be tabulated also before preservation.  

2. Put the organ into water until the smell of formaldehyde has disappeared.

3. Remove any thin outer membranes that may affect photography (especially light reflections)

and remove all small particles that do not belong to the specimen (except for epibionts).

4. Take the measurements/weight of the preserved in accordance with to the data table

specifications.

5. Take 2D presentation photos (as for the whole specimen) by either using a microscope camera

or the Nikon D500 camera and save the photos in photo folder 1. FRESH AND PRESERVED.

6. Is it necessary to use dyes (see Øresland & Oxby, 2021)?

7. Take test photos of the organ in a Petri dish in order to optimize correct lighting and natural

colours.

8. Take photos for z-stacking and save the z-stacked photo in photo folder 5. Z-STACKED

PHOTOS. At least five z-stacked “scale photos (at 90 degrees) have to be taken for later

scaling of the 3D model.

9. Start Agisoft Metashape 3D using the z-stacked photos (Part III).

10. Check if more z-stacked images are needed and if so, make a new 3D model.

11. Save the final 3D model in folder 7. FINAL 3D MODELS AND 2 D PHOTOS and make

BACKUPS

12. The organ can now be saved for later dissection and new photography or for other reasons

(e.g., dry weight).

TAKING PHOTOS AND Z-STACKING 

Microscope photography 

Photography should not be started before all preparations are done. When making a 3D model, 

the individual z-stacked photos should have (more or less) the same number of x and y pixels. 

This can be checked in NIS: Check Image Attributes once a photo has been taken or File > Open 

> Z-stacked photos > right-click a photo > Properties > Information or in Metashape: Photos >

Details > Size.  One can always right-click a photo > Show Info in order to see the number of

pixels. This is not a problem when using a compound microscope or a Nikon D500 camera.

However, z-stacked stereomicroscope photos may have very different numbers of pixels due to the

fact that stereomicroscopes have two light beams (although less z-stacking will reduce this

problem). All z-stacked photos will have almost the same number of x/y pixels when using a

stereomicroscope which is capable of providing a single light beam. Our Wild M3Z is equipped

with a Type S holder (fig. 6) where the microscope body can be moved to the left to select one

light beam. Other stereomicroscopes may provide other solutions. NOTE: check, regardless of

photo method, that the first three z-stacked photos, once taken, have approximately the same x/y
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size before proceeding! Try to keep the difference in pixel numbers between all photos to ~ 5 

pixels (reduce z-stacking if needed). 

Provide an image path in order to quickly save the photos in the correct folder. Go to NIS > Edit 

> Options > General: tick the box Use fix path for images; provide the path to the photo folder 5.

Z-STACKED PHOTOS; tick other relevant boxes; leave the “Temp” option as it is > Apply > OK.

Then choose Edit > Options > Save Next: choose the same image path as above in Directory;

Prefix seq 5 digits; Tiff format; Compression None; Next file to 1; tick Skip already existing files;

choose among options in Define image info > Apply > OK. We use the “Save as” option (rather

than the NIS Autosaving option) since we feel it provides a better control.

Z-stacking using NIS. When creating a z-stacked microscope photo the original photos used for

z-stacking are not saved. In order to z-stack photos, we first choose Acquire > Live fast and then

Applications > Real Time EDF Manually and tick the Align Images box. After clicking Start, and

once the two photos are opened, we begin by focusing the front of the right one and then, very

gradually, move to the back and click Finish. This takes approximately one minute. The photos

that are taken automatically are continuously being z-stacked, which is shown in the left photo. If

one is not satisfied with the result the whole process has to be redone. This software, with which

we have a long experience, fulfills all our requirements regarding quality, functionality, and

manageability; however, there are of course other similar software products available.

Start the photography early in the morning and try to take all the pictures within one day if 

possible since it is important for photogrammetry that the specimen does not change in appearance 

during the photography. Small specimens can be put in a Petri dish, supported underneath by 

small pieces of lead, or attached to a needle fastened to a piece of wood, which in turn is glued to a 

small turntable (fig. 4). Any unwanted large objects, like lead pieces, needles or metal bars, will be 

removed from the photo at a later stage. The specimen can then be rotated and turned over 

enabling the photos to be taken from all possible angles, especially if an oblique viewer is used 

(fig. 6). However, it must then be used for all photos. The order in which the photos should be 

taken  may depend on the object and how it is placed, but essentially it is the same for microscope 

and Nikon D500 photography (see below, Nikon D500 photography). At some point during the 

photography, one should take at least five z-stacked photos at a 90-degree angle of a flat area so 

the 3D model can be scaled (see below, Scale photos for the 3d model). One should try to take 

these photos at some distance from each other, if possible.  

Camera settings: NIS > Acquire > Camera Setting: exposure time to 100 ms; Offset to 0 and 

Gain, Gamma and Saturation to 1.0. Prior to taking the photos, it is important to check whether or 

not the compound microscope magnification (chosen objective) or the stereomicroscope 

magnification (chosen zoom knob number) matches the chosen magnification shortcode in the 

NIS access bar. After the photo has been taken, one should check this again and type OK in the 

NIS photo’s (right-click the photo) Image Properties > Image Fields > Type dialogue box to 

confirm that the information in the Optics box is correct. Otherwise, one should not to make a 

scale bar or any measurements in such photos!  

Note: DON'T crop or geometrically transform (i.e., resize or rotate) images. Metashape 

operates with the original images. If done, it will affect the autocalibration procedure - the process 

of the automatic estimation of calibration and distortion parameters. 
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Scale photos for 3D models 

In order to estimate the length, area and volume of the 3D model one must, during the modelling 

process, provide the distances between a number of known points in at least three flat z-stacked 

“scale” photos in order to create scale bars (in Part III, 3. Bundle alignment). The “scale” 

photos are to be taken at the appropriate time during the ordinary microscope or Nikon D500 

photo session (and be given their correct running number). It is crucial that these photos are 

aligned (Part III). 

1. IMPORTANT. At some point during the microscope and Nikon D500 photography, make at

least five (from which we later chose at least the three best ones) z-stacked “scale” photos of

different flat areas at a 90-degree angle (for accurate distance measurement) and name the

photo files with their running number + “scale” +1-5.

2. Save these “scale“ photos in the photo folder 5. Z-STACKED PHOTOS.

Nikon D500 photography 

The LED lighting on the flash and external lights can facilitate the focus setting. The LED light 

automatically goes off briefly when the photo is being taken. However, we often turn it off 

manually after the first photo in order to save the batteries, with the hope that we can focus the 

next photos correctly by a minimal movement of the rail. One can also see on the computer screen 

that the area in focus is changing. During z-stacking one should be able to take a new photo within 

five seconds. Change the Nikon D500 battery as soon as the Helicon battery indicator turns yellow 

and the current z-stacking is finished. The flash batteries will last longer than the camera battery 

but can be replaced at the same time to avoid interruptions.  

1. Insert the metal bar between the arms and the beak and the needles through the tentacles. Check

that the specimen is in a fixed position and that all areas can be photographed.

2. Check that the rail slider allows for focus on both the front and the rear of the specimen.

3. Focus on the front of the specimen and start the z-stacking.

4. Take the z-stacked mages from around the specimen by rotating the turntable, noting where the

first image was taken so that one knows when a 360-degree coverage (with an 80 % overlap)

has been reached. The rotation of the turntable between photos should be about 10-15 degrees

which correspond to 24 - 36 photos. If there is only one opportunity to take photographs (e.g.,

in the field) it is better to take them with even more overlapping, especially for areas with sharp

corners.

5. Start taking photos from above and around the top of the specimen paying attention to all sharp

edges and cavities. Lower the camera slightly (80 % overlap) and continue all around the

specimen until the turntable needs to be raised above the camera in order to continue from

underneath. Note that one can also turn the squid upside down on the black metal bar. In that

case, one should make sure that the photos taken before and after turnover are overlapping and

that the areas of overlap have not changed in appearance. Note that when the metal bar is

inserted through the squid mantle it will be damaged.

6. Photographing the arms and tentacles is demanding and time consuming. We recommend that

such photos should be checked for alignment and quality (above 0.5) in Metashape. Check the
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thumbnail photos (Show Cameras icon on the tool bar) surrounding the model and look for 

gaps that might indicate missed areas. A simple 3D textured test model (without scaling and 

error corrections) could also be made in order to determine whether or not more photos are 

needed (see Part III, Alignment).  

7. Do not forget to take five “scale photos” (see above). 

 

Z-stacking using Helicon software. The Helicon software was introduced in Part I. The Helicon 

Focus help function is very good and provides detailed instructions.  

In short:  

Helicon Remote: First, under File > Preferences > Image saving > Folder for images. Choose the 

TEST folder and these original photos can later be deleted since we have no use for them after 

z-stacking. The z-stacked photos (only) are saved in folder 5. Z-STACKED PHOTOS. We prefer 

to name the z-stacked photos with running numbers. Saving the project file is not really necessary.  

Check that the first z-stacked photo can be found. When taking photos manually, as we do, one 

should left-click on Stack on the toolbar and select Create new stack folder and previous photos 

are deleted from the Helicon Focus Source Images list in Helicon Focus (see below). Closing and 

opening Helicon Focus will also empty the Source Images list.     

 Helicon Focus: First, under EDIT > Preferences > Autoadjustments one must untick “Crop 

output automatically” otherwise the different z-stacked photos may get significantly different 

numbers of pixels. Other input values should be kept at 0 % and Depth map featuring to 3. 

If the photos were taken with Helicon Remote, click on its Helicon Focus icon; otherwise, open 

Helicon Focus separately and import the photos from your computer or camera memory stick:  

File > Open stack > double left-click a photo and all photos appear in Source images|. Check the 

photos for consistent brightness and quality by clicking on them one by one or use Pg up and Pg 

down.  

Below the Source images, there are three different rendering (z-stacking) methods (A, B, and C 

which should be tested in order to find the optimal one. They are often quite similar but will 

sometimes give different results (which is well explained in the help function). Do not mix 

different rendering options in a 3D model! 

The radius and smoothing options come next: the Radius is usually set at to 3. Being closer to 0 

provides the sharpest details but can give colours a helios effect at the edges. We set the 

Smoothing to around 3. Higher values give a darker image.  

Quick comparison of photos and settings before rendering. Choose Edit > Render preview to 

see the enlarged z-stacked photo, brightness variations and misalignments etc. One can also 

choose different rendering methods and other settings and directly compare the preliminary results 

in real-time mode. 

At the top of the screen, there are four options: Rendering, Retouching, Text/scale, and Saving, all 

of which are self-explanatory. Click on Saving and one will see the saving options to the right. 

Click on Save to save the z-stacked photo (with a running number) in photo folder 5. Z-

STACKED PHOTOS. One does not need to use the Save project file option.  

 

MAKE several backups of all your photos to external hard dries of which one should be kept at 

an external location. 
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In Part III, using Metashape, we start checking whether more photos are needed during the 

alignment procedure. When 3D modelling a specimen such as a squid, which can become dry and 

change shape, it is important to keep it moisten (using an ultra-fine spray, with distilled water, at 

least every 10 minute). The specimen should not be removed from its turntable until the 3D 

model is ready. 
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INTRODUCTION 

The Agisoft Metashape Pro (used here) and Standard editions are advanced software that are used 

for a number of 3D applications. Note that markers, the scale and measurement tools are available 

only in the Metashape Pro edition. In addition, there are free standing software such as Agisoft 

Viewer  and Adobe Acrobat, etc. that accept 3D models, which bypass the need for Metashape 

software in order to view the final 3D models.  

The latest Metashape manual can be downloaded from https://www.agisoft.com/ and should be 

used together with this guide. However, the manual is necessarily quite extensive due to its broad 

scope. The most important chapters in the Metashape Pro manual are Chapter 3: General 

workflow; Chapter 4: Referencing (e.g., camera/photos alignment); and Chapter 5: Measurements 

(distance, area, and volume). There is also a searchable help function in both the software and in 

the user manuals (where one can colour mark the text etc.). One can also find useful information 

in Knowledge base (https://agisoft.freshdesk.com/support/solutions). One should follow the 

Agisoft homepage and other 3D and photography internet sites in order to improve modelling and 

photography skills and to update the software. 

Part III is intended as a simple and practical introduction to Metashape and in particular its pro 

edition. Once one feels comfortable using this guide, one can start exploring the Metashape 

manual in detail and experiment with options and different processing parameters that are not 

mentioned here. To help beginners to get started, we only provide the information that is most 

relevant to the 3D modelling of small animals and we only describe how we ourselves created our 

first models and the mistakes we made. We detail, step by step, the basic modelling process for the 

final 3D model, and how to send and present it.  

We begin with a short description of the basic command structure and the general workflow. In 

Metashape there are often alternative options for opening panes and commands. We try to adhere 

to one option only to make things simpler. When they first appear, some of the features may not 

be easily understood, but they will all be explained in detail later on when we actually use them. 

The words “camera” and “photo” are used, more or less, interchangeable in this text! 

THE BASIC COMMAND STRUCTURE AND THE  WORKFLOW 

At the top pane, one will find: 

Left-click on any of these and drop-down options will appear which are self-explanatory. There is 

a toolbar under the top pane (View > Toolbar) with a number of icons with an explanatory text 

which appears when the mouse arrow is pointed at them. The icons light up when they can be 

activated and some have drop-down commands. We will refer to the relevant command options in 

detail, as and when they are needed. 

We begin with the first dialogue box (fig. 13) choices: Tools > Preferences > General. Choose: 

English, Point Cloud, Dark (or Classic or Light), Anaglyph, Parallax to 1.0, Decimal degree, 

https://www.agisoft.com/
https://agisoft.freshdesk.com/support/solutions


35 

Coordinate system units > Tick Check for updates and Write log to file > OK. Do not tick Use 

derived units if other units than meter are used.  

In the Advanced option > choose; Keep key  points and Keep depth maps > OK 

Note that the Metashape manual 1.8.4 describes all the parameters available in the different 

Metashape Preferences dialogue windows in Appendix C. Metashape Preferences. 

Fig. 13. Metashape preferences including check for updates and the log file. Note: Do not tick 

Use derived units if other units than meter are used.  
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Under View > select the three main panes below: 

1. Workspace: shows the Chunk which is the place where the cameras/photos are imported into

the project and the total number of markers and tie points that are used to connect the photos

are shown. Under Cameras, the individual photos are shown with their file names (we use

running numbers) and the NC is displayed if the camera is not calibrated (not vital for

microscope photos) and NA if not aligned. Below Cameras is found detailed model

information about Markers, Scale Bars, Depth Maps, etc. (left-click to see the information).

Chunks can be duplicated which is very useful since all camera/photos, markers, scale bars,

Alignment, Mesh, Texture  etc., can then be used in a separated model (but saved in the same

file). This is practical when one would like to test different modelling options without starting

from scratch.

2. Reference: shows different “quality” information regarding, e.g., Error (pix) and Projections

of Cameras and Markers as well as Distance, Accuracy and Error of Scale Bars. Move the

columns of interest to the left for easy access.

3. Photos: shows individual photos and their properties. View > Photos > Change View (a small

square icon to the far right on the Photos toolbar with drop-down options). One can here choose

to see the thumbnail photos in different sizes and by left double-clicking them brings them to

the screen (this can also be done from Details). Details will show, e.g., Aligned, Quality and

Size of each photo. Move the important columns to the left for quick access.

Note: if one right-clicks on a camera/photo in any of the above three panes a number of more 

frequently used options will appear. One can shift quickly between Reference, Workspace and 

Photos by clicking on their shortcuts in the bottom left corner of the screen. When opening 

Metashape the last used projects will appear at the bottom of the File drop-down list (above 

Exit). This function saves time. 

Workflow 

See Appendix I for all workflow settings. 

The 3D modelling workflow consists of  4-6 main steps depending on the chosen end result. 

1. Add Photos or Add Folder. Adding the photo folder is the quickest way to add multiple photos.

2. Align Photos. Common points (feature points) are located in the photos and matches are made

across photos into tie points. The result of this process consists of a tie point cloud containing

triangulated positions of key points matched across the images. In other words: Tie point:

where same feature has been recognized in multiple images. Key point: a distinct feature in one

single image.

3. Bild Dense Cloud. This is not dealt with here as we build a Mesh from Depth maps and since

Dense Cloud doesn't affect the texture for 3D model.

4. Build Mesh. Generates a 3D model (from Depth maps).

5. Build Texture. Texturing the 3D-mesh model gives it the final photographic appearance.

6. Build Tiled Model. Tiled models in TLS format can be viewed in Agisoft Viewer (which is a

free download software). In this guide tiled models are based on depth map data. They can only
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be built from the PSX format and can provide a very high resolution. They can be saved as 

*PSX (which is a project format) and as *TLS. “Hierarchical tiles” format is a good solution 

for city scale modelling since it allows for responsive visualization of large area 3D models in 

high resolution. However, it can be used for models of any size.  

 

Saving models 

The 3D project in progress is always saved in folder 6. 3D MODELS and different final versions 

in folder 7. FINAL 3D MODELS AND 2D PHOTOS. Save the project as a Metashape project file 

(*PSX) after each modelling stage and everything that was created in the project is displayed in 

the Workspace pane. If one creates a new copy of the project after each change one may may run 

out of memory.  We strongly recommend making backups of the photos and just save the of the 

project during the modelling. However, for the backups of final projects one should include the 

entire folder system, using the File > Save as command (not Copy). Note that the drive letter (C:, 

D:, etc.) may change during backup to other sources.  

The differences between the Metashape formats PSX and PSZ (not used here, but see Appendix 

III)) are well described in the Metashape manual. The Metashape Project file (*.PSX) basically 

stores the processing links between the  *PSX file , the *.files structured archive and the photos. 

This format enables responsive loading of large data (dense point clouds, meshes, etc.), thus 

avoiding delays on reopening photos.  

The various formats that can be used for, e.g., exporting, copying, sending and displaying textured 

models to others, are given in Appendix III. When copying and sending a textured PSX model 

one must include three items: the PSX model, the photos folder and the *files folder. Since Project 

files use relative paths to reference photos, one must always include the relevant folder structure 

when saving the project file to another location. If not, Metashape will fail to run any operation 

requiring source images, although the project file including the reconstructed model may be 

loaded up correctly.  

 

One  can disable Store absolute image paths option in the Metashape Preferences dialog window:  

Tools > Preferences > Advanced.  Store absolute image paths. We recommend enabling this 

parameter if project is not moved to another folder or computer. 

 

One problem encountered when backing up a 3D model to an external hard drive was that we 

could open the 3D model but not the photos correctly in the Photo pane (because Metashape could 

not find the them).  

If this occurs: 

a) Ensure that the photos have been copied to the correct folder (5. Z-STACKED PHOTOS) in the 

external memory. 

 

b) The path of the images may be wrong and thus need to be changed: Right-click on the Photo 

pane > Change Paths > All cameras and find your folder 5. Z-STACKED PHOTOS > left-

click on the photo that appears > Open. The path is now changed and the photos should appear 

correctly in the Photo pane. Right-click on a photo > Open, or double-left-click it to see the 

photo on the screen.                                                                                                                              

 

c) If the above does not work. Right-click on a single photo in the Photo pane or Workspace pane 

> Check Paths > All cameras. One may get the message: Some images are either missing or 

resized. One reason for this might be that some photos have a deviant size:  Photos > Change 
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View (icon on the Photos toolbar) and check in the size column for deviations from the normal 

x/y size. One should remove such photos after making new ones. Large differences in x/y pixel 

numbers (> 5 pixels) among z-stacked photos only occurred when we tested a stereomicroscope 

with two light beams (see Part II, Microscope photography). 

d) Check by choosing a photo in the Photos pane >right-click > Estimate Image Quality > All

cameras. One can now be able to see the quality estimates in the Quality column and the photos

can be shown correctly on the screen.

Note. When the same set of photos is used for different 3D purposes, it should be copied into the 

relevant project photo folders before starting a 3D project to avoid the path problem. We also 

once experienced that when photos in the Photos pane were opened, the colours were inaccurate. 

If that happens; the Show Depth Maps button on the Toolbar (fig. 14) should not be enabled. 

Fig. 14. Show Depth Maps button. 

ADD PHOTOS 

Here we will add all photos (including the five “scale “ photos) to the 3D model), check their 

quality and take new photos to replace any poor ones. Moisten the specimen frequently and keep 

the camera ready for complementary photography. 

1. Start a new project: File > New > Saves as (include the ID code in the project filename) in

folder D. 3D PROJECTS.

2. Click on Workflow > Add folder > select folder 5. Z-STACKED PHOTOS > Choose Single

cameras > Open.  The camera/photos can now be seen in the Workspace pane.

Save +backups (using Save as) 

Camera calibration 

After adding the photos, Metashape must be provided with some important camera data. The NC 

(not calibrated) found in Workspace pane > Chunk > Cameras indicates that the EXIF data 

available is not sufficient to estimate the camera focal length and a manual calibration is therefore 

required. Focal length is the distance from the sensor to the rear nodal point of the lens. Click on 

Tools > Camera calibration and in the dialogue box: in Camera type choose Frame and enter 

0.00422 mm in both Pixel size boxes (for Nikon D500 the pixel size is 4.22 μm). Contact the 

camera manufacturer for pixel size information. Enter 85 mm in the Focal length box if you use 

an 85 mm macro lens. Ignore other options. NC will be removed from the Workspace pane after 

aligning (see below). When using compound microscope and stereomicroscope cameras, 

Agisoft recommends not specifying the pixel size and focal length in the Camera calibration 

dialogue box since they may not correspond to the resulting image (the focal length changes with 
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zooming and change of objectives). This means that the NC will not be removed from the 

Workspace pane when using microscopes. 

Reference settings 

Here (fig. 15) we use Local coordinate system and specify information about units and accuracy.  

View >  Reference > Click on the wrench icon button to the far right at the top of the reference 

pane and in the Reference Settings dialogue box choose mm coordinate system; tick the Camera 

and Reference boxes; set camera, marker and scale accuracy to 0.001 mm (delete all old numbers 

first). Leave other settings as they are. Important: click on the wrench icon button again to check 

the input values. Obviously, the accuracy settings should be as realistic as possible and a 0.001 

mm setting requires that the glass slide micrometer scale photo allows for it and that the markers 

are set at pixel level. 

Fig. 15. Setting the Local coordinate system and Measurement accuracy. 

 Poor quality photos 

1. In the Photos pane > Change View (far right icon on the Photos tool bar) > Details > under

Label > right-click a camera/photo > Estimate image quality > All cameras > OK.
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2. Move the Quality column to the far left for easy access. Press the Quality heading to see the

quality in increasing order (low quality at the top).

3. Disable photos of a quality < 0.5 that appear in the Photos pane > Details > right-click on them

> Disable Cameras. One may occasionally have to accept lower quality photos if it´s

impossible to achieve better ones. Do not forget that photos with very different colours, due to,

e.g., that an organ has dried and become darker during the photo session, should not be used

since they may affect aligning and texture. The dry organ can also be smaller. It is therefore

extremely important to moisten the organs frequently (every 5-10 minute). Once an organ has

dried it is almost impossible to get it back to its natural appearance.

4. Make new z-stacked photos to replace the poor ones. Open the first disabled photo in

Metashape and open Remote Helicon or NIS (if a microscope photo is to be taken) so that the

two images can be compared. Make sure to obtain approximately the same frame view from the

Nikon D500 or microscope camera and try to take a better photo. Give the new photo a new file

name (same running number + new), and save it in folder 5. Z-STACKED PHOTOS. Add

the photo to the model: Workflow > Add Photos. Check whether the quality has been

improved: Photos pane bar > Details > right-click on the photo > Estimate image quality >

Selected cameras > OK.  Remove the old poor photo: right-click on it > Remove Cameras.

Take the remaining complementary photos. They should all be of an acceptable quality before

proceeding.

Save 

Note: Do not yet remove your specimen and camera and moisten the specimen frequently! 

Masking photos 

Before we start aligning the photos, we manually mask all unwanted areas. Masked areas will be 

excluded during feature point detection in order to improve alignment and quality of the tie 

points. This is important when using a turntable since the specimen is not static as regards the 

background. Masking can be used prior to; Aligning photos and when creating Mesh, Texture and 

tiled Models. Here we only mask photos in order to improve alignment (see Chapter 6. Editing in 

the Metashape manual for further information). Masks are available in both the Professional and 

Standard versions. 

Here we have a dark background, a rotating turntable and a camera whose position on its stand 

changes during the photo session. The background may therefore not always be completely dark. 

Tie points associated with the background and the metal bar will have a negative effect on the 

alignment process. Masks can to be created manually or automatically for each image (where 

possible). Here we show the manual method and mask all the photos where the metal bar is visible 

(fig. 16). One can also mask the entire background in all the photos but if the object is complex 

only a part of the background can be masked. 

1. Open a photo showing the metal bar from the Photo pane.

2. Left-click on Photo > Select one of the selection tools from the drop-down list, e.g., Intelligent

Scissors.

3. Select the metal bar area.
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4. Right-click the photo > Add Selection (or its icon on the toolbar) and a solid line is indicating

the selection made.

5. Select a photo > Click on the Show mask icon (white quadrant with a black circle) on

the toolbar and the selection appears/disappears.

6. Repeat for all remaining photos containing the metal bar.

Save 

The photos are now ready to be aligned. 

Fig. 16. A mask has been manually placed around the metal bar. Note that the arms could not be 

stretched out (see fig. 9). 
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ALIGN PHOTOS

Alignment is a critical and time-consuming part of the 3D modelling. Remember that many of the 

alignment problems, that we will deal with below, will not occur if optimal photos with good 

overlap and an optimal background are available. During alignment Metashape finds 

identifiable feature points (up to the maximum set Key point limit in the Align Photos dialogue 

box) and matches them across photos (up to the maximum set Tie point limit) as shown in fig. 17. 

If there are more than 150 photos one may choose not to use Generic preselection since it will 

take some time. However, it is really the photography that takes time. 

Workflow > Align Photos: See fig. 17 and Appendix I for all workflow settings. 

Fig. 17. The Align Photos dialogue box. 

Check the effect of Masking by comparing the alignment of unmasked and masked photos (fig. 

18). One can also compare the number of aligned photos and the quality of the tie points. If one 

does not want to use masks during alignment one can select Apply mask to: None in the Alignment 

dialogue box. 
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Fig. 18. These alignments with point clouds are based on stereomicroscope photos of a squid 

digestive gland (fig. 28). The background texture during the z-stacking photography was not 

optimal. The background of all photos was therefore masked. 

Save 

If the model is very small or cannot be seen in the Model view should make sure that Model, and 

not Ortho, is chosen on the Tool bar. Left-click on the Show Cameras icon> Show Thumbnails in 

order to locate the model. One can also try: Model > Transform Object > Move Object: the object 

is where the red,  green and blue lines meet. Right-click were the lines meet > Center View. Scroll 

the mouse courser forward or click the Zoom In button until the model can be seen. One often has 

to  use “Center View” a few times during zooming.   

We now have our first model (in Model view) consisting of a tie point cloud but this would appear 

incomplete if we didn´t have optimal quality photos, overlap and background. This is rarely the 

case and several actions with Metashape would be needed to improve the situation. We have 

already checked photo quality, but this must be repeated for all new photos. Check that the 

bounding box fits around the specimen: Model > Transform Region > Resize Region or Reset 

Region and Metashape will automatically configure the bounding box. Use also the other options 

in Transform objects and Region to resize, move, rotate, etc. 

A dialogue box will appear with the message “Some photos failed to align”. To align such 

photos: View > Photos > Details > Click on Aligned so that the unaligned photos appear at the 

top of the column > Select the unaligned photos > Align selected Photos and some of them, it not 

all, will be aligned. 

Save 
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Below we will deal with areas of the specimen that have not been photographed, the use of 

Markers and photos that are still unaligned or have few projections. Note the number of 

aligned photos (Chunk > cameras (number of aligned/total number of photos)) in order to follow 

the success of the following actions. 

Areas that have not been photographed 

Open View > Workspace, Photos, and Reference. 

1. Centre the model cloud by double-left clicking on it. The thumbnail photos can also be viewed

(click the camera icon in the toolbar, Show Thumbnails) together with their file names

(Model > Show/Hide Items > Show Labels). The rotation of the turntable between photos

should be about 10-15 degrees which  corresponds to 24 -36 photos.

2. Downsize the model (scrolling the mouse) and rotate it (Model > Transform Object > Rotate

object) and the camera positions then appear from different angles (fig. 19).

3. Examine the model and its surrounding thumbnail photos and identify areas that need more

photos. Click on a photo in the Photo pane and a red rectangle then appears around the

camera position (if it is aligned). Take notes of where cameras are absent and where the

nearest ones are available.

4. Take all new photos that are needed to cover a particular area but do not move the camera or

the specimen before the area has been covered in full. It is easier and much quicker to take

new photos when needed if the camera is already in position for photography. Do not forget

to moisten the specimen.

5. Save the new photos in folder  5. Z-STACKED PHOTOS (file name: use the nearest aligned

photo number + missing + a running number).

6. Workflow > Add Photos > select the new photos in folder  5. Z-STACKED PHOTOS.

7. Align again: Photos > select the new photos > Workflow > Align Photos.

8. Did the missing photos align? Check their photo quality (as above, Poor quality photos).

At this stage, it can be difficult sometimes to judge whether any more photos are needed. In such 

cases we just proceed to the next step. 

Save 
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Fig.  19. Camera positions in four circles around a squid specimen. In this case, photos are needed 

from below the squid.  

Markers   

It often happens that some of the photos are still unaligned, mostly due to poor photo quality 

and/or poor overlap (both of which we tried to correct by taking new photos). One can then either 

disable or remove the photos (if they are not needed) or try to align them. However, in some 

situations, e.g., when taking photos in nature or for photo technical reasons, one may not be able 

to take better or more overlapping photos. One would then need to boost Metashape´s alignment 

by placing markers to small pixel clusters (easily identifiable feature points) in the photos, thus 

enabling connections (tie points) to be made between them. Aligning photos using markers is 

particularly useful when one needs to couple chains of photos together and close holes in the 

model. Markers are only available in the Pro version. Note that markers cannot be of use in all 

cases, which emphasizes the importance of taking good photos with at least 80 % overlap from 

the start. 

Markers are indicated by flags: 

Green flag = a marker that is manually placed on the photo after checking its position. 

Blue flag = an accepted marker point with matching tie points/pixel clusters. The blue markers are 

automatically placed on the images by Metashape. 

Grey flag = an uncertain position which, if corrected, becomes green. In many situations they are 

just left as they are and of no use. 

A red/white line = a helpline to manually place a marker in another aligned photo. Note that the 

helpline may not always cross the optimal marker position. 
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We will now deal with three alignment issues: 1. Unaligned photos; 2. Photos with few < 150 

connections and 3. Partly aligned photos that are placed in different Components (see below) and 

we will use Markers to align the cameras/photos.  

Opening photos for marker placement 

The principle here is to Place markers in four easily identifiable and identical points in four (if 

possible) nearby aligned photos and all the nearby unaligned photos. This marking procedure is 

the same for the three alignment issues. If there are separate areas of the specimen having these 

problems one will have to repeat the procedures described below for each area.  

Opening  the photos: right-click the first aligned photo in the Photo pane > Open in New Tab and 

the photo appears on the main window and its file name is shown on the window pane above the 

photo. Repeat this for the remaining aligned and unaligned photos and all photos will appear in 

the same Tab group. Right-click on the first aligned photo >  Move to Other Tab Group and we 

will have two Tab groups as shown in fig. 20. All chosen photos are now available for markers to 

be placed. Click the letter X next to the file name to remove any unwanted photos from any Tab 

group.  

Fig. 20. The digestive gland of the bob tail squid Sepietta oweniana. The photos 8-15 and 12 are 

in two different Tab groups and photos 15 and 12 are shown side by side with four identical 

markers.  
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Applying markers for aligning photos

We will now open the first aligned photo and Place four markers in it (fig. 20) and then clarify 

their positions on the remaining three aligned and all nearby unaligned photos. When the Place 

marker option is used on at least three aligned photos, those markers will be automatically 

placed on all remaining photos where possible but their positions must be checked.   

1. View  > Toolbar > left-click on Show Markers (the large flag icon to the right) and the marker

flags will be seen on the photos when markers are applied. If the Show Markers option is not

enabled the Marker dialogue box will not appear.

2. Zoom the first and the second aligned photos to high magnification (pixel level), and find a

good marker point that is clearly visible in all the selected photos.

3. Place markers. Right-click on a good point in the first aligned photo > Place Marker > New

Marker. A  green flag named Point 1 appears (marker points are automatically given a running

number). If not visible, click on the large flag icon on the toolbar. A grey flag and a red-white

help line will now appear in the second aligned photo. The position of the grey flag must be

corrected. Left-click on it so that the flag dot turns red and move it to the supposedly correct

position where the flag will turn green (manually placed marker).

4. Marker Point 1 will appear in the Reference pane under Marker. Place three more markers

(that do not lay on the same line) in the first two aligned photos.

5. Select the remaining nearby aligned and unaligned photos, one by one,  from the first Tab

group and Place markers 1-4 in them using the Place Marker submenu (point 1 - 4).

6. Photo pane > Select (Ctrl and left-click) all the unaligned selected cameras/photos > Right-click

> Align Selected Cameras (it is important not to use the reset alignment option). NA (not

aligned) should now disappear for the unaligned cameras in the Workspace pane and the

thumbnail photos in the Photos pane should be ticked in the upper right corner. An Error (pix)

estimate and the number of Projections can now be seen in the Reference pane > Marker.

NOTE: Right-click a Marker in Reference pane  > Show Info and all photos with that markers will 

be shown. This is a very practical option when placing and checking markers. 

Applying markers to photos with few projections  

It is important that an aligned camera/photo has >100 projections (projections of valid tie points) 

after the Error corrections (see below) in order to optimize the model. The goal is therefore to 

make sure that all photos have well over 100 projections before the Error corrections are made. 

The reasons for low projection numbers are bad photo quality, insufficient overlap and inefficient 

use of the images as shown in fig. 21. The primary action, however,  should be to increase 

overlap by taking additional photos! 
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Fig. 21. A photo of a digestive gland with inefficient use of the image.

A small number of projections can lead to poor alignment quality (orientations of the image will 

not be correct or distorted) and the result of the alignment of the images will affect the quality of 

the texture. Therefore, we need to identify such images and increase their numbers of projections 

by adding markers if no more photos can be taken. If there are only one or two nearby photos 

available, one should place many markers on all of them. 

To identify photos with few projections: Reference > sort the Projections  table in increasing 

order. One can also see projection details for each photo: Photos > View Matches. Select a photo 

at the top bar and its valid matches to other photos then appear.    

1. Open the first photo with the lowest number of projections seen in the Reference Projection

table. Then open all nearby photos and Place many markers in all photos. Check the View

Matches to see matches to nearby photos.

2. Align the selected photos and check the change in number of projections in the Projection table.

Add more markers if the number of projections is not well over 100 (if possible).

3. Repeat for the remaining photos where the number of projections is not well over 100.

Applying markers for aligning Components   

Subsets of cameras/photos can, after the alignment process, be split into different Components 

that are displayed in the chunk's content of the Workspace pane (fig. 22). Such subsets of photos 

have not been aligned with each other. Only Component 1 is shown when all photos are aligned 

together. 
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Fig. 22 Chunk content with Component information. 

Parts are groups of photos that are aligned with each other only if they appear in the same 

Component (fig. 23). Cameras that are put into different Parts, during the Metashape alignment 

procedure, are used for alignment analysis which we do not deal with here.  

Fig. 23. Chunk content showing Parts within two Components. 

The marking process for components is almost identical to that for aligning photos. 

1. Double-click on the first Component and make it active and open four nearby photos and

move the first photo to a tab group of its own on the right side of the screen.

2. Place four markers in the first photo: Place Marker > New Marker in the first photo and then

use the Place Marker submenu to copy the markers into the other three photos. A red-white

help line will appear. Remove these photos (click on X) but keep the first one on the right side

of the screen.

3. Double-click on the next Component and make it active and open four nearby photos on the

left side of the screen.

4. Continue the marker placement operation for the four photos using the existing marker

selection (point 1-4) from the Place Marker submenu.

5. After all Components / cameras  been aligned: Workspace > Components >  Merge

Components.

Save 

https://s3.amazonaws.com/cdn.freshdesk.com/data/helpdesk/attachments/production/31043408369/original/7c1hKQ-3oSZOF1ImRRXk62tYdV_UjdRC8Q.png?1665589887
https://s3.amazonaws.com/cdn.freshdesk.com/data/helpdesk/attachments/production/31043408170/original/rW-FHrZ7ny0OwcGEANoHOOmvSUBPlplb1A.png?1665589444
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ERROR CORRECTIONS AND MAKING  SCALE BARS

All photos, including the scale bar photos, are now aligned but the 3D model must be improved. 

We will optimize the model by removing/reducing any errors in the Point cloud and by creating 

scale bars (which add supportive reference data to the 3D project so that distance, area and 

volume can be estimated).  

We used the following parameters: 

The goal of the following optimization and filtering procedures is to reduce each camera (photo) 

Error (pix) value to <1.0 whilst preserving a high Projection value  > 100 (both given in the 

Reference pane > Cameras). Keep the Reference pane open during the entire correction and scale 

bar procedure and monitor the changes.  

Error (pix) is the mean square reprojection error for the marker calculated over all photos where 

it is visible. Projections is the total number of projections of valid tie points in a photo. Tie points 

are the numbers of acceptable connected points between a pair of photos.  

Before starting the error correction procedure, one should: 

1. Make sure that any previously made Marker boxes in Reference  are unticked until just before

the final filtering method, Reprojection Error, is started.

2. In Reference > cameras: sort the individual photo Errors (pix) in descending order. Error and

Projection values will change during the correction process described below, and their values

should be monitored.

3. Right-click on the model > Center View (or double left-click on it).

4. Check that the bounding box fits around the specimen. Model > Transform Region > Resize

Region > left-click the specimen and turn it around.

Optimization and Filtering 

When observing the Sparse cloud (the four dots icon on the top pane) of the 3D model, one can 

see that several dots are obviously wrong (e.g., they are outside the specimen) and need to be 

removed.  

Four optimisation/filtering methods can now be utilized: 

1. Reconstruction uncertainty (filtering)

2. Projection accuracy (filtering)

3. Bundle alignment (making scale bars)

4. Projection error (filtering)

Within each of the above filtering methods 1, 2, and 4, three steps are repeated a number of 

times until the target levels are achieved (while reducing Error (pix) and maintaining as many 

Projections as possible):  

1. Detection of unwanted  points



51 

 

2. Deletion of filtered red points 

3. Optimize cameras  

 

Reconstruction uncertainty  

This procedure helps to remove outlier points of little value. Double Left-click or Right-click the 

3D model cloud, centre and enlarge it and then go to the top pane on the screen: select Model 

>Transform Object > Rotate, so that all irrelevant points are visible during the filtration. Keep the 

Marker boxes in the reference pane unticked. 

a) Choose Model  > Gradual Selection > Reconstruction uncertainty.  Note the current value 

(on the left under the slide bar). The target level is 20-40.  Start with 70 by moving the bar to 

the right > OK and filtered points will then turn red. Do not reduce more than 50 % in each 

step (if  >50 % use Edit > Undo and use a higher value). 

b) Delete red points: Edit > Delete selection.  

c) Tools > Optimize Cameras and monitor the Projection value (>100) and Error (pix) (should be 

reduced). Accept general (green) settings and always choose Estimate tie point covariance > 

OK. 

Repeat these steps (usually 4-5 times) until a level of 20- 40 is reached.     

 

 Projection accuracy  

This procedure removes projection errors by filtering points of large size. Points are clusters of 

pixels and consequently smaller clusters reduce the variance of the point position estimations. 

Keep the Marker boxes in the reference pane unticked. 

a)  Choose Model > Gradual Selection > Projection accuracy. The target level is 2-3. Start at 40.    

Sometimes there will be a high reduction of the key points and the target level cannot be 

reached.  

b) Delete red points: Edit > Delete Selection.  

c) Tools > Optimize Cameras. Accept general settings only and choose Estimate tie point 

covariance > OK). 

Repeat these steps (usually 4-5 times) reducing the level until a level of 2-3 is reached.     

Save  

 

                                                                                                                                                 

Making scale bars  

The bundle of aligned photos is now ready for real-life constraints such as scales and we attempt 

to increase the model accuracy by creating at least three scale bars, using markers, which make 

it possible to estimate lengths, area and volume. A scale bar is essentially a known distance in 

the model. Adding more scale bars would eventually reach a "no significant value" point. One 

can monitor the refinement of Scale Bars Total Error in the Reference pane as each scale bar is 

added.   
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We create scale bars in three simple steps:  

1. In NIS, we create and burn a distance line together with length data into copies of at least 

three of our five z-stacked “scale “ photos taken at 90 degrees (see Part II, Microscope 

photography) that were saved in folder 5. Z-STACKED PHOTOS and aligned together with 

all other z-stacked photos. We save these burned copies in folder 2D SCALE PHOTOS. If we 

need more than three scale bars, we can use the remaining  two “scale” photos. The burned 

copies with a distance line and length data must never be deleted since they enable a check of 

scale bar accuracy. The burned copies will also be saved in their own camera group in 

Metashape and disabled (see below).  

2. In Metashape, we open the first pair of photos: the burned copy with a distance line and length 

data and the aligned original “scale” photo, side by side. We Place markers in the aligned 

scale photo at points that correspond exactly (at pixel level) to the two endpoints of the burned 

distance line. We then Place the same markers on three more aligned photos. This process is 

repeated for at least two more  “scale” photos. 

   

3. In Reference > Scale Bars pane we add the distance that was burned into the copy.  

 

 

Creating a distance line in NIS:  

1. Open NIS and choose the correct short cut calibration on the NIS access bar (e.g., 40wild1.0x 

or Nikon D500 85 mm 0,35). Check that a correct distance can be measured on a glass slide 

micrometer (see fig. 11) or a ruler (fig. 12). 

2. Open the first scale photo from folder 5. Z-STACKED PHOTOS 

3. Zoom in on two easily identified microstructures (they must be some distance apart and in an 

absolutely flat area of the photo). Make sure that the two identified microstructures can be 

found in at least three nearby photos. Measure the distance between them. Burn the distance 

line into the photo together with the estimated distance in µm in large font size (fig. 24) and 

save the photo (file name: running number + burned) using “Save as”, in folder 3. 2D SCALE 

PHOTOS. Repeat for at least two more scale photos.  

 

   

 

Fig. 24. A “burned “ photo with a distance line and its estimated length.  

  Creating a scale bar in Metashape:  
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1. Open Metashape and add the three burned photos: Workflow > Add photo > select (Ctrl + 

left-click) the burned photos in folder 3. 2D SCALE PHOTOS > Open. Select the three 

photos in the Photos pane > right-click on them and choose Disable Cameras. A red dot 

appears in the disabled cameras and photos. 

2. Make a special camera group for the disabled burned photos so that they can be found easily: 

Workspace  > Select the three burned photos, right-click on them and choose Move Cameras 

> New Camera Group. 

3. Right-click on the new camera group “Group 1” with the burned photos > Rename > and name 

it “Burned”.  

4.  Check that the previously selected Reference Settings are correct: View > Reference > Click 

on the wrench icon button to the far right at the top of the Reference pane and in the Reference 

Settings dialogue box, choose mm coordinate system; tick the Camera and Reference boxes; 

set camera, marker and scale accuracy to 0.001 mm. Leave the other settings as they are; > 

OK. Click on the wrench icon button again to check the input values. 

5. Open the first pair of photos in different tab groups, the burned one with a distance line and 

the original scale photo, and place them side by side in different Tab Groups on the screen: 

Workspace > Chunk > Cameras > right-click on the photo >Open in New Tab > Move to 

Other Tab Group.  

6.  Zoom in the burned photo to pixel level where the burned distance line starts and the 

corresponding area in the scale photo and place the first marker on it that corresponds to the 

start point of the burned distance line: Right-click > Place marker > New Marker and do the 

same for the end point of the distance line (fig. 25).  Be very precise when doing this!  

7. Both markers are now appearing with a green flag and different Point numbers in the 

Reference Markers pane. Give new names to the pair of markers in the Reference Markers 

pane: Right-click on the first marker > Rename and change the point name to, e.g., 55scale1a 

(running number of the photo, Scale1 is the first scale and a is the first marker) and do the 

same for the second marker and named it 55scale1b (repeat this naming procedure for the two 

remaining pairs of scale photos). It is important that one knows on which photo a scale bar is 

based if problems occur with the length and volume estimates and rescaling is required. 

8. IMPORTANT. Clarify the marker positions on the image by adjusting the position of each 

marker on at least three nearby aligned images. Left-click the grey flag dots in those 

images and they will become red and adjust their positions. Their flags will turn green after 

adjustment. This will create more projections and provide a better precision for the scale bar.  

9. Select the first pair of markers (Ctrl and left-click) in Reference Markers pane (both marker 

areas become darker) > right-click > Create Scale Bar. The two markers then appear as a 

scale bar, with a joint name, in the Scale Bars pane.    
 

10. Click on the View Source icon (a small square icon) in the Reference pane heading and m    

should change to mm in the Scale Bars pane.  
 

11. In the Scale Bars pane > double left-click under Distance (mm) and enter the scale distance 

(that was burned into the burned photo in µm) in mm. 1000 µm is one mm. Use a full stop, 

not a comma, in the scale distance. Note that the scale box is now ticked (fig. 26). 
 

12. Repeat all above and create at least two more scale bars using remaining pairs of “burned” 

and “scale” photos.  
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13. Check that the scale bar boxes are ticked. The scale bars contribute to the adjustment

procedure, however,  if one believes that the scale bars have poor accuracy, they should not

be included in the optimization process and their boxes should be disabled.

14. Update transform (the icon with two blue arrows) in the Reference pane heading (fig. 26) in

order to apply the changes and Error (mm) will be shown.

15. Tools > Optimize Cameras (or click on the Star icon in the Reference pane heading) improves

the model estimation. Tick the Estimate tie point covariance in the dialogue window and

accept the green default choices > OK. The Point cloud will now be reconstructed and

when finalized the Ruler icon should light up!

16. Check the distance estimate: Open all the aligned “scale” photos and click on the Show

Marker (large flag icon on the top pane). Choose the Ruler icon at the toolbar pane and

measure the distance between the first and second scale markers. Measure close to the

markers but not on them. Check that the distance is the same as given in Reference > Scale

Bars distance (mm) for each photo. Do not (yet) worry if these tests show some minor

discrepancies. Later, when the 3D model is finished, we will check the accuracy of distance

estimates made on the final 3D model against the scale photos. However, again, it is

extremely important that both the burned distances and the scale markers are correct and

based on easily identifiable points in all photos that are used for making scales. See Make a

Report how to include tests of model accuracy.

Fig. 25. Distance line for a scale bar. Four nearby not yet opened photos (59, 57, 56 and 55) and the 

58 scale photo and the 58 burned one with its burned distance line and length data. The two markers, 

58scale1a and 58scale1b, correspond to the start and end points of the burned distance line. The two 

markers will be placed on the nearby (minimum three) photos. 
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Fig. 26. Markers and three Scale Bars with distance given in mm. The green rectangle shows the 

Update Transform  icon. Accuracy was estimated in the Reference Settings dialogue box (wrench 

icon inside the blue rectangle). The numbers of projections are few since the markers were not yet 

placed in nearby photos. 

Note that it is important that the assumed accuracy in the Reference Settings dialogue box is 

realistic in relation to one’s scale photos, scale markers and scale bars since the Error estimate and 

the length, area and volume estimates could otherwise be affected! 

Note that after adding or changing any information in the Scale bars section of the Reference 

pane, on must press the Update button and Optimize Cameras in Tools apply the changes. 

Save  

Reprojection Error 

The reprojection error in a photo is the distance between two projected 3D points on the photo, 

the reconstructed and the original one. The reprojection error demonstrates the accuracy of point 

positioning and is specified in pixels. During the reprojection error filtering process one sets the 

criterion to how many points in the Dense Cloud one wants to delete. One should change the 

viewing angle of the model so that most of the points are visible during this process in order to 

check which point are highlighted before deleting them. 

Tick the scale bar boxes. 
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a) Model > Gradual Selection > Reprojection error. We often use the target level 0.3-0.4. Start

with 0.7. If  reduced by more than 10%: press Edit >Undo and try a higher value. Note that

this target level is not generally recommended since higher levels might be preferred

depending on the camera used, etc. One should not to delete to many points since it may lead

to a small number of tie points.

b) Delete red points. Edit > Delete Selection.

c) Tool > Optimize cameras. Accept general (green) settings and always choose Estimate tie point

covariance > OK.

Repeat this until the preferred target level is achieved. 

Save  

MESH  

1. Model > Transform Region > Resize Region and make sure that the  bounding box fits around

the object.

2. Choose Workflow > Build Mesh. See Appendix I for settings in the dialogue box.

If one gets the message Empty surface it means that that the Bounding box is misplaced during 

Build Mesh operation and doesn't contain any information.  

Save 

Editing the mesh 

Background features and other unwanted features that could negatively affect the final model 

should be removed, as per some of the various methods described below. Test different methods 

on duplicates of the model in different chunks; Click the Workspace > right-click on the Chunk 

> Duplicate. In the dialogue box select Depth Maps > OK. Give each new Chunk a name that

corresponds to its purpose. Remember to right-click on the Chunk > set active when a model is to

be viewed (and modified).

Remove unwanted points and objects. One can remove either individual or groups of points 

manually. Select Model > Free-Form Selection) and delete the selected points: Edit > Delete 

Selection. Click on the Arrow button on the Toolbar to rotate the model so that all unwanted 

points can be detected.  

Mask defocus areas. One may have  blurred areas in the photos which may affect the sharpness 

of the final texture. One can then automatically apply masks to such areas (based on the depth 

information of each point) in order to exclude them prior to the texture blending. 

1. Select Tools > Mesh > Generate Masks.
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2. In the Generate Masks dialogue  box (fig. 27) select suitable parameters. Click on the OK 

button when done. 

 

 

Fig. 27. In Generate Masks we can automatically apply masks to areas that are out of focus. 

 

Colour calibration: (Tools > Calibrate colours). Use this option only if there are big light 

differences in photos. Obs: this can create bad colours and be time-consuming! Make the colour 

calibration in a new Chunk! 

White Balance: Tools > Calibrate Colours > Sparse Cloud > Calibrate white balance. White 

balance should be done during the photography and used here only if there are considerable light 

differences in the photos. Note that the use of white balance here could cause error in the colours. 

Make the white balance in a new Chunk!  

Save  

 

 

Photoshop photos before texturing. Before starting texturing: make any necessary photoshop 

changes on the inferior photos. 

1. Copy the original the z-stacked photos that need to be modified to folder 6. Z-STACKED 

FOLDERS FOR PHOTOSHOP and make any necessary adjustments on the inferior photos. Do 

not change the frame size by cropping nor the file name. Save and exchange the “photoshop” 

photos for the original ones in folder 5. Z-STACKED PHOTOS. 

2. Repeat: Editing the mesh model as above if needed. 

Save  
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 TEXTURE   
1. Click Workflow > Build Texture. See Appendix I for settings in the dialogue box.  

Save   

 

 

Editing the texture  

In order to light up the model and adjust the contrast one can use: Tools > Set Brightness. Another 

option would be the Remove lighting tool which smooths out the dark and light areas of the model. 

Make the texture editing in a new Chunk and rename the new Chunk to Lighting. Select Tools > 

Mesh > Remove lighting. Use the Colour/ Multi colour mode if the model has different colours at 

first trying the given presets. Compare the two models by alternately setting the chunks to 

“active”. Check the results carefully when using this option for scientific purposes.  

 

One can also use the Agisoft Texture de-lighter (*dlz) software which is a free stand-alone tool 

designed to remove shadows from model textures, although in principle the photographs taken 

should reduce such problems to a minimum. This software requires user input only in the form of 

rough brush strokes marking lit and shadowed areas. It is optimized for 8-bit JPEG compressed 

textures and does not need specific image formats with greater depth of colour. It can be 

downloaded for free from Agisoft. To get started: From Metashape > Export your model in *OBJ 

format to folder 7. FINAL 3D MODELS AND 2D PHOTOS and import it to Texture de-lighter: 

File > Import Model. Click on the Blue palette, mark the shadowed areas and then click on the 

Yellow palette to mark the areas that are too light. Use the pointer to move the model around. 

Finish by clicking on the  Remove Cast Shadows and Remove Shading. Save the model and, if 

needed, Export the model in any of the other available formats. Check the results carefully when 

using this software for scientific purposes. 

 

Save as: Id code+de-lighter1.dlz in the folder 7. FINAL 3D MODELS AND 2D PHOTOS and in 

this format the model opens directly in Texture de-lighter.  

 

 

   

 MEASUREMENTS   

The estimated scale lengths are now tested for accuracy in the 3D model. Open one of the 

“burned scale” photos with a burned distance line and length data and open the textured model. 

Rotate the model so that it appears identical to the burned photo. Zoom in them both and select the 

large Ruler icon at the top toolbar. Left-click in the model at the corresponding start and end points 

of the burned distance line in the photo. Are the distances identical? Right- and then left-click 

outside the model to remove a measurement. Repeat this process with the other burned “scale” 

photos. Make a note of the differences in length estimates between the model and “scale “ photos 

(to be added to the Report, see below). Then estimate the area and volume (which should also be 

added to the report): Tools > Mesh > Measure Area and Volume. Are the estimates realistic! Note 

that if the 3D model is not closed, the volume option will not appear and area estimates would 

thus be incorrect!  

With Metashape the volume of our rubber specimen (fig. 7) was estimated to be 1162 mm3, which 

is comparable to the volume estimates (water displacement method) we made earlier. After 
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making 32 estimates we obtained a mean of 1245 mm3 (minimum 1138 mm3 and maximum 1453 

mm3) but a minor overestimate of the true volume was to be expected in view of the method used. 

We concluded that the Metashape volume estimate for small specimens works well, although of 

course the accuracy of any estimate is entirely dependent on that of the scale bars and the 3D 

model itself. 

Save As: File name IDcodefinal3D1 in folder 7. FINAL 3D MODELS AND 2D PHOTOS  

Make backups ! Use Save as. Check the model can be opened using backups. 

See APPENDIX III for a 3D model (fig. 28) which can be viewed in the PDF version.  

 

 

 

BUILD A TILED MODEL  

The tiled Metashape models comprise more than 12 000 polygons (often >1 million). They are 

often used when 3D modelling large structures but can also be used for any other sizes. Tiled 

models (in the TLS format) are used, e.g., in the Agisoft Viewer which is a free of charge viewing 

software for textured models. See Appendix III for further instructions.  

 

1. Open your textured model and check that the object is within the bounding box. If not, drag the 

corners and select Model  > Transform Region > Reset Region or use the Move, Resize and 

Rotate options. 

2. Workflow > Build Tiled Model    

 

3. Choose in the dialogue box: Source data: Depth maps or Mesh; Quality: High or Ultra-high; 

Face count: Medium; Depth filtering: Mild; tick the Enable Ghosting filter box. If Depth maps 

are used one can choose among Quality options. Ultra High means that the original z-stacked 

photos are used, but it takes time, and one could instead use Reuse depth map (if Medium 

Quality is selected), to save time. Face count specifies the maximum number of polygons in the 

final mesh. We always chose the time demanding options (if we get a better result) since it is 

the photography that takes most of the time during 3D modelling.  

 

Note. If small holes were repaired using the Tools > Mesh > Close Holes option, one cannot use 

the depth maps for making a Tiled model. This option applies only to the Mesh which then 

should be used for making a Tiled model. 

 

4. Export the Tiled model in the Agisoft Tiled Model Format *TLS: File > Export > Export Tiled 

Model.  

 

5.When saving a Tiled model in folder 7. FINAL 3D MODELS AND 2D PHOTOS 7 one will 

find an Export Tiled Model dialogue box with information regarding the coordinate system: 

check that the local coordinates are in m (not mm) > OK. Agisoft Viewer cannot yet handle 

mm in the coordinate system but distances can be given in m, cm or mm depending on the 

estimated distance. 

 

Use “Save as”: IDcode+tiled 1 with a *TLS extension  
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Due to the configuration of our computer operating system our Tiled models have an Adobe 

symbol in front of their  file names. However, such files cannot  be opened in Adobe photoshop. 

6. Save the Tiled model with *PSX format (in the Metashape project).

7. View the *TLS model in Agisoft Viewer: File  > Add layer (one cannot use Open) to import

the model.

MAKE A REPORT 

Whilst a 3D model report is extremely useful and important and should be mandatory for 

scientific 3D model documentation, it is also of value for non-scientific 3D models. The report 

should therefore, together with the 3D project`s data file, be kept in the same folder as the final 3D 

model. A report provides quick and exact information as to how a particular model was made. It 

has a title page with notations and the date, followed by the survey data, camera calibration, scale 

bars, digital elevation model, camera calibration data and parameters of the process. Make a note 

of the differences in length estimates between the model and the “scale “ photos and the area and 

volume estimates. One can also include the 3D model in a PDF report (see Appendix III). Making 

a report in Metashape is simple:    

1. File > Export > Generate Reports: In the dialogue box one can write the title and the 3D

project file name plus other information of importance > Save as pdf in folder 7. FINAL 3D

MODELS AND 2D PHOTOS.

Save as: ID code+ final 3D 1 report 
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APPENDIX I: WORKFLOW SETTINGS 

In order to save computer memory capacity, one should save all workflow work in the same file 

in folder 6. 3D MODELS using the project ID code. Do not forget to make backups to several 

external memories. 

Below we show our most common workflow settings. 

1. ADD PHOTOS/FOLDER

Save (+backups) 

2. ALIGN PHOTOS

Accuracy

Highest or High 

Generic preselection /Source 

Reset current alignment (only when starting all over with new alignment) 

Advanced  

Key point limit: 40 000 

Tie point limit: 4000-10 000 

Exclude stationary tie points (removes background points) 

Apply mask to: key points or tie points 

After alignment: Check that the bounding box fits around the object. Use the resize, move, and 

rotation tools found in Model > Transform Region options. Delete all bad points outside the box: 

Model > Free -Form Selection > select the bad points area > Edit > Delete Selection. 

Save (+backups) 

3. DENSE CLOUD

Dense Clouds are not needed for our 3D models.

Quality

High or Ultra high

Depth filtering 

Mild 

USE: Resume depth maps if saved earlier as Dense cloud. 

Calculate point colours, ALWAYS 
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Calculate point confidence: ALWAYS 

This takes some time. When finished: Model/Transform Region/ resize and make sure that the  

bounding box fits around the object. 

 

Save (+backups) 

 

 

4. BUILD MESH                                                                                                                                    

General                                                                                                                                        

Source data: Depth maps, ALWAYS 

Surface type: Arbitrary (3D) 

Quality: Ultra high 

Face count: high 

Advanced                                                                                                                                

Interpolation: enabled (default) 

Depth filtering: mild (no reuse of depth maps) 

Calculate vertex colours: not needed for depth maps 

Save (+backup) 

 

 

5. BUILD TEXTURE 

Before texturing: 

Remove unwanted points and apply Masks. 

 

Do photoshop changes (if needed) on the copies of z-stacked photos (do not crop them) and keep 

the same file codes as in the original z-stacked photos).  

 

One can do a Colour calibration (Tools > Calibrate colours) before texturing but only if there are 

big light differences in photos. Obs: this can create bad colours and be time-consuming! 

One can also calibrate the white balance at this stage (in the same dialogue box). However, the 

white balance of photos should also be checked before adding them to Metashape.  

 

Then build the texture model: 

 

General 

Texture type: Diffuse map, ALWAYS 

Source data: Images, ALWAYS 

Mapping mode: Generic, ALWAYS 

Blending mode: mosaic, ALWAYS 
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Texture size/count USE SUGGESTED 4096-16000 

Advanced   

Hole filling, ALWAYS (but not  first time, in order to detect missing photos). 

Ghost filter, ALWAYS (some thin structures or moving specimens failed to be reconstructed and 

use this to avoid ghosting effects). 

Save (+backup) 

6. Build Tiled Model

General      

Source data: Dense Cloud 

Leave Pixel and Tile size as they are given 

Face count: Medium (specifies the maximum number of polygons in the final mesh, should not be 

too low or too high). 

Advanced   

Ghost filter (if some thin structures or moving specimens failed to be reconstructed (to avoid 

ghosting effects). 

Reuse depth maps > Ok 

Save 

Note that the tiled PSX model is still open in Metashape and it has a PSX* extension on the top 

file name bar.  

Now we export the tiled model to get a TLS format: 

File > Export >Export Tiled Model 

“Save as” IDcode+tiled 2 TLS with an *TLS extension in folder 7. FINAL 3D MODELS AND 

2D PHOTOS. 
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APPENDIX II: SOME COMMON BUTTONS  

 
Be familiar with these functions before exploring others. 

 

FILE 

Open  

Save 

Save as 

Export (one can export and save  models and generate reports) 

Import 

Upload Data: to internet resources (4D Mapper, Cesium, PointBox, Pointscene and Sketchfab) 

Last in the drop-down: One can see the last projects that have been opened: Open from here is 

quicker. 

 

EDIT 

Undo 

Delete selection 

 

VIEW 

Capture view (save a photo) 

Different panes: Workspace, Reference, Properties, Photos 

Animation (video) 

Toolbar 

Full Screen (click it again to go back to normal, useful during MAKING  SCALE BARS when 

one need to zoom in. 

 

WORKFLOW 

Add photos 

Align photos 

Build dense Cloud 

Build Mesh 

Build texture 

Build Tiled Model 
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MODEL 

Navigation (quicker to  use the large arrow icon on the Toolbar)  

Free form selection  

Gradual Selection (for ERROR CORRECTIONS) 

Ruler (quicker to use the Ruler icon on the Toolbar) 

Transform objects (move, rotate) 

Transform regions (move, rotate and resize). When using the Resize option both region and the 

object can be rotated simultaneously which is very useful during ERROR CORRECTIONS. 

View mode (different views appear in the toolbar when available. This option is therefore an 

alternative to choosing among the large model icons on the Toolbar. 

 

PHOTO (open a photo first) 

Different selections tools. Click the Large arrow icon on the toolbar to go back to normal. 

Show/Hide, e.g., Show Masks, Show markers and Show Points (very useful) 

 

TOOLS 

Markers 

Mesh  

Camera Calibration 

Optimize Cameras 

Set brightness (has its own  Toolbar icon) 

Preferences (language, etc, very important ) 

 

HELP 

Content 

Check for Updates 

About Metashape 
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APPENDIX III: VIEWING AND SHARING 3D MODELS  

3D models can be viewed and sent to others using different software, which requires appropriate 

model file formats. Metashape offers many different file formats (but some of them are of less use 

to the beginner). Metashape itself uses two formats, the *PSX and the *PSZ for saving a project. 

Such 3D models are not suited for e-mail due to their large size and instead one can use Google 

Drive, Dropbox or other cloud storage services.  

 PSX files (Metashape project file) is used when saving 3D models during the modelling process 

(see Part III Saving models) and for export in other formats. The *.PSX file stores the links to the 

processing results in the *.PSX file and the data itself in *.files (a structured archive in a yellow 

folder with the 3D model name). When copying and sending a PSX model one needs to send 

three things; the  *.PSX file , the *.file folder and all the photos (folder). 

PSZ (Metashape project archive) files are ZIP compressed. PSZ models are saved from the PSX  

model: Edit  > Save as > chose the latest psz format > Save. When copying and sending a PSZ 

textured model, one only needs to send the PSZ file. Some data may be lost during saving in some 

formats, e.g., the Tiled format, but one will get a notice before saving starts. The PSZ models can 

only be opened in Metashape.    

To export a 3D model: 

1. Select Export Model... command from the File menu. 

2. Browse the destination folder, choose the file type, and the file name. Click the Save button. 

3. In the Export Model dialogue specify the coordinate system and indicate the applicabl export 

parameters to the selected file type. 

4. Click the OK button to start the export. 

5. The progress dialogue box will appear displaying the current processing status. To cancel                 

processing click the Cancel button. 

Metashape supports model export in the following formats: 

• Wavefront OBJ (*.obj) 

• 3DS file format (*.3ds) 

• VRML models (*.wrl) 

• COLLADA (*.dae) 

• Stanford PLY (*.ply) 

• X3D models (*.x3d) 

• STL models (*.stl) 

• Alembic (*.abc) 

• Autodesk FBX (*.fbx) 

• Autodesk DXF Polyline (*.dxf) 

• Autodesk DXF 3DFace (*.dxf) 

• Open Scene Graph (*.osgb) 

• Binary glTF (*.glb) 

• U3D models (*.u3d) 
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• Adobe PDF (*.pdf) 

• Google Earth KMZ (*.kmz) 

 

Agisoft Viewer                                                                                                                               

This stand-alone free software is practical since anybody can download it and use it to view your 

tiled 3D models in the TLS format (only one file to send). The options are relatively simple and 

self-explanatory. The Agisoft Viewer will show length in m, cm or mm  Note that the tiled model 

must be set to m (not mm) in Metashape Reference Settings and choose in the Agisoft Viewer: 

Tools > Preferences > dialogue window: General; Mode: Anaglyph; Units: Coordinate system 

units and tick the Use derived units box. Check the distance estimates against the corresponding 

burned photos distances. 

 

Open a tiled model:  

1. Select Add Layer (not Open) from the File menu 

2. Chose the tiled TLS model (with a photoshop icon in our case) > OK  

The model will now be displayed in the Viewer workspace and on the Layers pane.  

Save as  ID code+viewer1vpx in the format Viewer Project *.VPX in folder 7. FINAL 3D 

MODELS AND 2D PHOTOS. 

The VPX model can be opened directly in Agisoft Viewer: File > Open. 

 

Making videos of 3D models (in both Agisoft Viewer and Metashape)                                        

Below we show one of the quickest ways to make an mp4 video that can be viewed in, e.g., 

PowerPoint, PDF, Windows Media Player and as attached to an E-mail. Open the 3D model in 

Metashape. To the right in the windows screen there are four small icons: camera, video 

recorder, screenrec gallery and screen settings which are self-explanatory. Using the video 

recorder: Click it and mark the area around the model > after count down > move the object 

around > Stop >  Save (by clicking the small Save video locally icon under the video) in folder 7. 

FINAL 3D MODELS AND 2D PHOTOS with the ID code + a name of choice. In the video, one 

can make measurements and draw in the volume/area estimate value box, make measurements,  as 

well as use the pointer to pay attention to certain parts of the model. The result is saved 

automatically in the Screenrec Gallery (but only with a date/time file name, regardless of the file 

name in the 3D MODEL folder. From the gallery one has direct access to all videos and photos (as 

PNG) and the Preview option. It may be useful to play the video a 2x speed if many arrows and 

measurements are shown  (which take some time to carry out during the recording).  

 

We do not go into details regarding the use of 3D models in various other software since they are 

continuously being developed and occurs in many different editions. 

 

Adobe Acrobat  

In Acrobat, one can open and view a 3D PDF model created in Metashape. A 3D model (*U3D) 

can also be inserted into a PDF document using, e.g., Adobe Acrobat Pro. 

PowerPoint                                                                                                                                       

3D models and videos can be viewed. 
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Word

3D models and videos can be viewed. 

3D viewers 

A quick way to view models. 

Excel

3D models and videos can be viewed. 

Online        

Uploading of generated data (Dense cloud, Textured model) to various online resources: 4DMapper, 

PointBox, Pointscene, Scetchfab: File > Upload Data. 

Finally, we show a 3D model of the digestive gland of the bobtail squid Sepietta  oweniana using 

our stereomicroscope camera (fig. 28). In the PDF version of this guide, this model can be zoomed 

and rotated. This is an incomplete model and we show it in order to illustrate some of the 

problems that can occur during the photography. The digestive gland has some holes due to poor 

overlap and to the fact that some of the photos could not be used since the organ was not 

moistened as frequently as it should have been, resulting in discolouration and shrinking. We 

could not model the octopus Eledone cirrhosa shown in fig. 9. The reason is that the specimen had 

been preserved in 4% formaldehyde prior to the mounting on the preservation tube and the arms 

could therefore not be stretched out in full in the preferred positions for photography, despite 

being in water for 24 hours. In other words, optimal objects and photography is the key to 

successful 3D modelling! 

Fig 28. The digestive gland of a bobtail squid (Sepietta  oweniana) to be viewed as a 3D model in 

the PDF version. 
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Divers and Scientists West Coast Sweden is sponsored by: 

Agisoft Metashape is a cutting-edge software solution, with its engine core driving 

photogrammetry to its ultimate limits, while the whole system is designed to deliver industry 

specific results relying on machine learning techniques for post-processing and analysis tasks. 

SI TECH is a Swedish company focusing on development, manufacturing and marketing of 

innovative safety solutions for protective suits such as; drysuits, rescue suits and similar protective  

garments. SI TECH is rooted in the diving industry and this is still the company’s core market. 
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